Sign in with
Sign up | Sign in
Your question

ASRock CODE 19 ERROR

Last response: in Motherboards
Share
April 7, 2012 8:09:35 PM

I just bought:

ASRock Extreme3 Gen3 Motherboard (Z68 chipset)
Intel i7 2600 (not K)
8GB (2x4) Corsair Vengeance 1600mhz CL8 (CMZ8GX3M2A1600C8)
Leadtek GTX560 2GB GDDR5 - 256 bit
Seagate Barracuda 2TB - 7200 rpm - 64MB
OCZ Z-Series 550W PSU

the problem is this:
I put everything together, in a brand new chassis, all plugged in, all looking good, I pushed the power button, all the coolers start, hard drive starts, etc, nothing shows up on the screen, I pull the chassis door and notice on the motherboard the error code 19 (which in the ASRock Dr. Debug manual stands for - "Pre-memory South Bridge initialization is started"). from what I read on the internet it looks like the bios version that the motherboard ships with is somewhat obsolete and doesn't cope with either the cpu or the corsair memory modules. apparently it's necessary to flash the bios to a newer version to make it run. if that is the case, the problem I'm facing is that I cannot update the bios version since I cannot see anything on my screen. it's completely blank all the times. Yes, I cleared the CMOS, yes I tried to remove the memory and used just one module in the A1 slot, yes I ran out of options. If anyone is familiar with this code 19 error on the ASRock extreme3 gen3 motherboard and knows how to solve it, I would be eternally grateful. I'm beginning to regret I bought the ASRock motherboard. I've known that ASRock was a bad brand in the past but I read a lot of good reviews about this MB model so I decided to give it a shot. Bad bet.

Any help is appreciated at this point.
Thanks.

More about : asrock code error

a b V Motherboard
April 7, 2012 9:23:04 PM

From ASRock site in Memory Support information for that board:
Note6: It is recommended to install memory module in DDR3_A2 or DDR3_B2 slot first!

I've seen a few other instances of this, and unfortunately, boards were RMA'd.
You can try putting one module of RAM in th A2 or B2 slot and try maybe a different display port or even try different RAM in one of those slots first and then may need to RMA. That is a very popular board and the reviews are far more positive than negative. Everyone gets a bad part now and then.

April 7, 2012 9:25:43 PM

yes, I installed the memory in A2 B2 first, then as an alternative I tried different slots with no result. I also checked on a different display port. same result.

I'm thinking about RMA now...
Related resources
a b V Motherboard
April 8, 2012 2:28:01 AM

Contact tech support first and let them know about the error, since there are other threads on the net regarding the issue, they're definitely aware of it and my have a solution to prevent having to RMA.
April 8, 2012 11:44:15 AM

I just contacted ASRock tech support today and after I sent them the same detailed description as posted here, I got a reply where they were basically telling me to contact the dealer I bought it from. Long story short, they were telling me it's not their problem and I'm pretty much on my own. I hope the dealer service can do something about it. Whichever the case, I learned my lesson. Next time I'll go with MSI.
a b V Motherboard
April 8, 2012 3:47:12 PM

That sucks.
I've never used anything but ASUS and MSI, but seems ASRock has been more helpful in some of the other threads I've seen. If there is a way to try different RAM first, might be worth it before going through the trouble of having to return it.
!