Sign in with
Sign up | Sign in
Your question

Remote desktop cannot connect through interenet?

Last response: in Networking
Share
August 8, 2010 11:00:49 AM

HI

I have managed to get my windows remote desktop to work through my local network but I cannot get it to work over the internet.
I have opened port 3389 on my router thomson gatewate 585 v7.


So I have some basic questions that Im not sure if I understand.

Should I be able to connect through the interenet from within my home network , to test it, so that instead of putting in my local IP 192.168.1.91 I put in my static internet IP 81.134.156.189 ?
I dont have another way of testing it without travelling quite far and it didnt work when I did try once last night.

Secondly I dont understand how my internet IP 81.*.*.* is enough for the remote desktop software . Surely it also needs the internal IP addres of the computer its connecting too? SO it should read 81.134.156.189 \ 192.168.1.91? But this doesnt work either.

I am also trying VPN but I cannot get that to work either. aarrggg

thanks for any help
remainz
August 17, 2010 6:54:16 PM

If your can connect to your other computer and vice-versa on your LAN, remote desktop is working fine.

The key to connect outside your LAN is to port forward the connection to an IP address in your computer.
Now log in to your router using the web interface and then click on applications/games tab. There go to port forwarding, depending on your router there might be more than one tab for port forwarding just click the first option. Next to start type: 3389, and next to end: 3389 then put the IP address of your PC ( I would recommend you to assigned a static IP adress on your PC).

To test the connection, it would be ideal if you can do it from a computer outside your LAN. The reason is, sometimes it can cause conflicts in you router, however go ahead and try it and see if it works.

Testing the connection requires you to use "remote desktop connection" so go to it and put your external IP address follow by a colon something like 81.*.*.*:3389. NOTE use the external IP address not your router IP address neither you PC IP address.

Let me know!
July 15, 2011 4:48:09 PM

I am running Win XP Pro and in process of setting up host and client machines. What I am getting from this is that Microsoft doen't tell you that in order to use the RDC outside of your access point router is to use port forwarding in you router so that the IP address can be used on the desired computer to connect to the client computer. This makes sense as there is no way typing an IP address will connect without redirection. Verizon Actiontech has a nifty little video that explains how to set up port forwarding using the router software which includes firewall settings. Other than that, it looks like it could be done over a web-based server, VPN or third party software.

I am remote now but will go home to verify that connection is possible on my home network. If so, I am going to enable port forwarding and test on a different wifi connection. Web based

I would be interested if anyone can verify what have found with RDC issue but right now I am favoring third party software which will essentially solve all connectivity issues and suspect better with IP addresses vs names(NAT).
August 25, 2011 3:01:45 PM

Am I right in thinking you shouldn't have to forward ports? Or that Microsoft should tell you how to do this?
The simple response to that is that they can't, not every router is the same, and they DO tell you to forward relevant ports.

The technology exists as it does, the firewall will point incoming connections based on certain points, the PCs that it then sends the data to will be 'listening' (if they have been configured to). This is the same for more than simply RDP (port 3389), but for everything e.g. a PPTP VPN connection will use 1723.

I really hope that I've got what you said confused, as if you don't know how the technology works, I don't feel that you have a right to complain. :non: 
!