Sign in with
Sign up | Sign in
Your question

Asus GTX 570 Woes!

Last response: in Graphics & Displays
Share
February 21, 2011 12:55:59 AM

Hello, community.

I picked up a brand spankin' new Asus GTX 570. I plugged it in, installed it's drivers from disc. I shut the machine down so I could put the casing back on, as well as, essentially, restarting the PC as the driver installer wanted me to do.

Well, done and done. And nothing.

By nothing, I mean that the bells and whistles on my Sandy Bridge board are running, but no signal seems to be sent to either of my displays.

I'm an ATI guy. This is my first switch to Nvidia. Now, here's the deal... the only thing I can think of being the issue, is that I forgot to rip out my old Catalyst drivers.

I threw back in my Sapphire 4870 hoping that it would load some junk up, but no, that'd be too simple.

Any suggestions, team? I googled the webs and webbed the googles, and no, I couldn't seem to find a similar problem, but as the internet goes, I could have just been using the wrong search phrases. If there is a similar, topic, I'd appreciate being linked to it.

Thank you all in advance.

Not having access to Windows 7 kinda' makes it hard to begin work on my final school project, a demo reel for 3D Animation. I choose the wrong time to get down with this switch.

More about : asus gtx 570 woes

February 21, 2011 1:06:29 AM

Boot to safe mode and remove all drivers (related to graphics card) you have in your pc, reboot. If you manage to boot back to Win, install this little program called Driver Sweeper (link here). Restart, and boot to safemode again, then run Driver Sweeper. In program make a Tick in : ATi- Display; Nvidia- Display, Nvidia- Physx, then click "Analyse", if it finds something click on "Clean". When done it will ask you to reboot. Reboot your PC. Download & Install fresh drivers from Nvidia web.

Report back

Cheers,

V.
m
0
l
February 21, 2011 3:04:37 AM

So I threw back in the 570, and mysteriously things worked again. I did manage to run the Driver Sweeper program and then reinstall the drivers from the official online sources-- which admittedly, I should have done from the get-go, yo.

I wonder if, honestly, it was as simple as me not shoving the bits into the PCI-E slot far enough. My case seems to stretch the cards to their limits and it's pretty hard to secure them down with screws. I wonder if it just wasn't in their perfectly. Which is weird that I would've messed up doing that with both my 570 and my 2 year old 4870.

I love that number, apparently-- **70!

Anywho, thank you for the prompt response and suggestion of Drive Sweeper, yo!
m
0
l
Related resources
a c 80 Î Nvidia
a b Ĉ ASUS
February 21, 2011 3:41:41 AM

You likely did not have it seated well. At post, there are no drivers to use. If it was not functioning at boot up, drive sweeper has no effect. You probably just didn't have it seated well and the 2nd time you put it in, you fixed it.
m
0
l
February 21, 2011 9:36:28 AM

You're welcome. And yes it could easily be badly seated card. Didn't come up my mind silly me, mind that it was 4 am here, meh :) 
m
0
l
February 21, 2011 3:33:28 PM

Use driver cleaner pro and make sure to uninstall all the drivers...and reinstall the new driver from the nvidia website...
m
0
l
February 21, 2011 4:21:02 PM

As was already stated by other member, me and OP, card probably wasn't seated well.
m
0
l
!