Sign in with
Sign up | Sign in
Your question

M5A97 Pro playing silly begger's!

Last response: in Motherboards
Share
April 10, 2012 2:22:32 PM

Hi there peeps :hello: 

I have an issue with my Asus M5A97 Pro motherboard, its decided that it doesnt want to see the onboard Ethernet or S/Pdif ports. So i'll lay down the facts as i know them and hopefully you guys can help me out!

Right! well ive had this computer for about 3 months now and all was going well but i decided i was going to put in a new power supply and 2TB hard drive. They both came, i get all excited and go to fit my new toys. They went in no problems and i installed windows 7 64 on the new hard drive, it all booted no problem then i plugged in my ethernet cable but it wasnt detected, which is strange because it was working fine up until the fresh install of windows.

I tried all the tricks in the book to get it to work but it just wasn't showing up in device manager which makes me sad :sweat:  so i just up and bought a PCI ethernet card and it works fine, but now ive found that my S/Pdif doesnt seem to be working either, it shows up in playback devices but when i set it to default i get no sound and the red light doesnt light up! very annoying indeed! so no ethernet or S/Pdif off my MB

So after all that what i want to know is if my motherboard is broken and needs sent back, or have i just been a noob and done something wrong?
April 10, 2012 9:09:13 PM

Thanks for the reply itzdanielp! Now i suppose i should've mentioned in my previous post that i have already downloaded the drivers for all of the above, and that has done exactly nothing :(  I also found a website that said that the NIC could have gone into "deep sleep mode" and to wake it up take out the ram and cmos battery. So i tried it and thats not working either....

Related resources
a b Ĉ ASUS
a c 121 V Motherboard
April 11, 2012 3:18:48 PM

Have you tried resetting the BIOS?
April 11, 2012 11:00:52 PM

I've tried flashing the bios with 4 different versions from the asus website to see if it was incompatibly, but no joy. I used the Asus EZ Flash to do it, but it all seemed to work. Is there a way to reset the bios to factory settings?

That may be where the problem came from actually, i did update the bios just after i installed the new components, cant for the life of me remember if it was before or after i started to get the issues tho :\

Thanks again for the reply :) 
a b Ĉ ASUS
a c 121 V Motherboard
April 12, 2012 3:22:46 PM

Separate from flashing the BIOS there is a jumper down towards the bottom of your MB that will wipe out all the settings. It won't revert it to a previous version though.

Double check your manual for the exact location. You are looking for the CMOS_Clear Jumper
!