Closed

Does this sound like a dead CPU?

Background: System is about 10 months old.

RAM: 3x2 GB Corsair Dominator (DDR3 1600; http://www.newegg.com/Product/Product.aspx?Item=N82E16820145224)

PSU: Corsair 750Wv2 http://www.newegg.com/Product/Product.aspx?Item=N82E16817139021

CPU: Intel i7 930 http://www.newegg.com/Product/Product.aspx?Item=N82E16819115225

Case: HAF X

Heatsink: Xigmatek Dark Knight

Video Card: PNY Geforce GTX 470 (http://www.newegg.com/Product/Product.aspx?Item=N82E16814133341&Tpk=pny%20470)

New Mobo: EVGA x58 FTW3 (http://www.newegg.com/Product/Product.aspx?Item=N82E16813188065)

I decided to switch motherboards (was using a Gigabyte) to a new one due to dead SATA ports. I originally chose to use an ASUS Rampage III formula (http://www.newegg.com/Product/Product.aspx?Item=N82E16813131666).
Board arrived, I installed. I got no post (no beep codes). Bummed, I followed the Tom's Hardware instructions for a no post. I switched to some old RAM (timing matched), an 850 W Corsair PSU, and still no post. I removed and reseated my CPU. No post. My case fans would begin to move when I powered on, but my CPU fan wouldn't move (nor would the LED on it light up). Asus had me boot up with no memory, and still no beep code. I removed the board, tried to breadbox, and no post.

I decided then to RMA to the EVGA x58 FTW3 (listed above). As I waited for it to arrive, I reinstalled my old motherboard. I posted on the first try (however, dead SATA ports, so couldn't do anything with it).
The EVGA motherboard arrived. I installed. Boom. No Post. Same issues as above (no post, heatsink fan/led did not light up), and no beep codes (this board has a built in system speaker).

Does this sound like a CPU that I messed up when removing my original motherboard?
6 answers Last reply
More about does sound dead
  1. It posted on your old mobo, right? Sounds like CPU is not the problem.
  2. Incompatibility then?
  3. Double check that you're using the right ram slots. When I got my 1156 board, I put the sticks in the slots I thought I should be using. It didn't boot. When I saw that I had the ram in the wrong slots, I moved them, and I'm currently using the computer now.
  4. The CPU is the last component that you should suspect as being faulty, much more likely is incompatibility with your memory. I am puzzled as to why the fan is not running though as this does not depend on the CPU to run to work. The fan not running may cause the board not to post. Are you sure that you have plugged the CPU fan into the correct connector?
  5. http://www.tomshardware.com/forum/310192-28-post-bios-related

    New thread! I stumbled upon people having the same problem as me with the i7 930 (link to that thread is within the above post).
  6. This topic has been closed by Mousemonkey
Ask a new question

Read More

CPUs Product