Sign in with
Sign up | Sign in
Your question
Closed

X79 and PCIe 3.0

Last response: in Motherboards
Share
April 11, 2012 10:20:42 PM

I'm planning for an Intel 3930 on an Asus Sabertooth X79, with two GTX 680's in SLi. Here's what I've heard.

Currently, the GTX 680 is not supported at PCIe 3.0 speeds on X79 motherboards.

NVidia says it's in the process of certifying some X79 motherboards for 8 GT/s speeds, and Ivy Bridge will be Intel's first native PCIe 3.0 chipset.

Intel's Sandy Bridge E datasheet says the processor is 'capable of up to PCI Express 8.0 GT/s', and has two x16 lanes. On the website, Intel lists the chips as PCIe 2.0.

So, if the CPU and some motherboards are capable of 3.0 speeds, what makes it not native?

Does the X79 chipset not support the speed, and the motherboard manufacturers get around this with some electronics trickery? If so, will this extra link in the chain become a liability once 3.0 speeds are used? Or if SLi is used?

Or, is it some other new PCIe 3.0 thing, besides speed, that the X79 won't support?

In other words, is X79 3.0 not equal to Native 3.0?

More about : x79 pcie

Best solution

a b å Intel
a c 715 V Motherboard
April 11, 2012 11:51:45 PM
Share

Interesting, misleading and somewhat wrong. The SB-E has 40 primary PCIe lanes, 32 lanes of PCIe 3.0 are dedicated to the GPU(s), all LGA 2011 CPUs & MOBO's are capable of PCIe 3.0, some BIOS upgrades have addressed PCIe 3.0 issues, but the X79 Chipset is a controller for 6 SATA ports (2xSATA3 & 4xSATA2) and USB 2.0 14 ports using an additional separate 8 lanes of PCIe 2.0. Ditto the Z77 has the same 8 lanes of PCIe 2.0. Meaning, the IB (Ivy Bridge) is the second set of CPU's from Intel to run PCIe 3.0 to the GPU(s). All LGA 1155 including the IB have half the number of PCIe lanes to the GPU in comparison to LGA 2011; SB/LGA 1155 16 lanes of PCIe 2.0, IB/LGA 1155 16 lanes of PCIe 3.0 vs SB-E/IB-E/LGA 2011 32 lanes of PCIe 3.0 to the GPUs then split in various ways.

You are confusing a Chipset with GPU lanes. Before with LGA 1156 e.g. P55 and LGA 1366 e.g. X58 the GPU(s) ran through the Chipset, but since Sandy Bridge LGA 1155 and Sandy Bridge Extreme LGA 2011 all GPU lanes are a direct path to the CPU to reduce 'latency.'

Therefore, the SB-E running e.g. GTX 600 series or HD 7000 series GPU(s) is PCIe 3.0 clean *IF the drivers allow it. The problem is with nVidia, the SB-E & AMD HD 7000 series runs PCIe 3.0 just fine. Yes, I've seen this -> http://www.geforce.com/hardware/desktop-gpus/geforce-gt...
*GeForce GTX 680 supports PCI Express 3.0. The Intel X79/SNB-E PCI Express 2.0 platform is only currently supported up to 5GT/s (PCIE 2.0) bus speeds even though some motherboard manufacturers have enabled higher 8GT/s speeds.

BTW - Registry fix (hack) to force the GTX 680 to run in PCIe 3.0 mode; see - http://tinyurl.com/7awc9lv (RMPcieLinkSpeed, DWORD = 0004, etc. IMO - It's a bad act by nVidia...to Disable, if this is an issue on some LGA 2011 then the driver installer 'should' detect and notify the end user to rectify vs all LGA 2011 suffer from the few LGA 2011 with a BIOS issue.

Problem this might be ditto with the IB, since there's no difference in the PCIe 3.0 spec on either the SB-E or IB. The HD 7000 series does run in PCIe 3.0 mode on LGA 2011.

You may want to read - http://www.techpowerup.com/162942/GeForce-GTX-680-Relea...
GeForce GTX 680 supports PCI Express 3.0. It operates properly within the SIG PCI Express Specification and has been validated on multiple upcoming PCI Express 3.0 platforms. Some motherboard manufacturers have released updated SBIOS to enable the Intel X79/SNB-E PCI Express 2.0 platform to run at up to 8GT/s bus speeds. NVIDIA is currently working to validate X79/SNB-E with GTX 680 at these speeds with the goal of enabling 8GT/s via a future software update. Until this validation is complete, the GTX 680 will operate at PCIE 2.0 speeds on X79/SNB-E-based motherboards with the latest web drivers.

Ivy Bridge and Z77 Chipset (Panther Point):


HD 7900 Series running PCIe 3.0 on SB-E:


GTX 600 Series running PCIe 3.0 on SB-E (fix applied):
Related resources
April 13, 2012 6:25:50 AM

Best answer selected by sectrix.
a c 328 V Motherboard
April 13, 2012 11:09:46 AM

This topic has been closed by Nikorr
!