Sign in with
Sign up | Sign in
Your question

I think my mobo is doa

Last response: in Motherboards
Share
April 11, 2012 11:37:10 PM

Hi everyone so i bought a motherboard a asus p867 deluxe i just got it. Upon removing the plastic cap i saw that a few of the pins were bent on it. So i went to the internet and found a tutorial on how to bend them back with a mechanical pencil so i did so. Now i don't have a case seeing as i am recieving it tomorrow so i decided to breadboard it. Okay now here is the problem i have i plug the psu in and the power turns on then off immediatily. I have tried two PSUs and they both do the same thing so i am curious on how to do it. Also if your wondering how i am turning it on the motherboard has a button for power so i used that. I have tried taking the battery out for a minute to reset everything and that did nothing at all. I wish to use my new computer i have had so many problems with it.

More about : mobo doa

a b V Motherboard
April 12, 2012 12:12:10 AM

Try a clear CMOS? if that doesnt work..maybe it is DOA :( 
m
0
l
April 12, 2012 12:28:47 AM

I already said i took the battery out to reset everything so is it just my luck that it is DOA. If so should i return it to the manufacturer and explain that the MOBO's pins were bent upon arrival or the retailer and say the same thing, i bought it from newegg.
m
0
l
Related resources
a b V Motherboard
April 12, 2012 12:31:16 AM

Oh sorry mate, i must have missed that part :(  I'm not familiar with the return policy in the States, but I'd RMA it back to newegg.
m
0
l
a c 156 V Motherboard
April 12, 2012 12:48:07 AM

You need to have a CPU installed. You have "normal" results without a CPU.
m
0
l
April 12, 2012 1:04:23 AM

By CPU installed do you mean installed in the socket if so i did that and tried with and without one installed same result. I tried with and without ram and still the same thing. Wow this is really horrible i am about to take my money elsewhere when i buy a MOBO from now on seeing as this is the second one i got from newegg that something was wrong with it. The first one was DOA also, also how do i test to see if my processor or something else is the problem and not the mobo. I dont think that my PSUS are at fault i'm thinking something is wrong with my CPU or something. The first MOBO i got to work but it sucks because half of the board doesn't work and it boots to windows and then quits when doing stuff like i was running the windows scoring thing and it shut off in the middle.
m
0
l
!