Sign in with
Sign up | Sign in
Your question

Computer won't boot anymore

Last response: in Components
Share
July 28, 2011 7:54:18 PM

Hello everyone.

I was on a holiday for two weeks with my computer unplugged from the sockets. I came back home today and heard that my girlfriend had used it yesterday for while connecting every single cord to a extension cord with 13 outlets (and the extension cord in a single 230 V @ 50 Hz) (don't know if this matters or not I thought it might be worth mentioning). There was also a thunderstorm, but she claims she unplugged the cords before this happened.

Now the computer won't boot at all. It starts, but the usb devices and monitor are dead. MemOK! led flashes every second (according to Asus this means that there's a problem with the memory). I tried to do as Asus advices me to do, which is to press the MemOK! button for a couple of seconds and then the motherboard does somekind of memory tests and such. It didn't work. I also took off the memory blocks, but for no use.

My specs are the following

Asus M4A89GTD PRO / USB3
Phenom II x6 1055T
8 Gigs of Kingston 1333MHz memory
550W of Antec power
ATI Radeon HD 5850

No overclocks at all.

Please say if you need more info. I'm writing this on my gf's Macbook and I hate it.

Thank you.

PS. I didn't really know where to post this, so if this is the wrong section for my question, please feel free to move the thread.

More about : computer boot anymore

July 28, 2011 8:14:05 PM

Please tell me you're using surge protectors...
July 28, 2011 8:22:33 PM

Yes, there's a surge suppressor on the extension cord.
!