Sign-in / Sign-up
Your question

Extreme3 Gen3 – Can’t access UEFI or Boot Selector after OS install

Tags:
  • ASRock
  • Hard Drives
  • Motherboards
Last response: in Motherboards
April 12, 2012 2:27:26 PM

My first build went smoothly until I actually turned the machine on. I took my old hard drive out of my Dell (a 320GB Seagate Barracuda) and stuck it in my new build. The old drive had Windows Vista Ultimate and I didn’t wipe it or anything before installing it in the new build. So this is Dell software on this thing.

Now, when I turned the machine on for the first time I had no problem getting to the UEFI. Interestingly, though, I didn’t get the ASRock startup screen (http://www.asrock.com/news/events/201102ex/IDB3-3.png). I got the codes 98, 99, and A3 in the bottom right corner (I’ve since set the SATA mode to AHCI, which yields the code A2, I believe) and then it would just boot up Vista from my old hard drive.

I restarted and got into the boot selector and set it to my USB stick so I could install Windows 7. I wiped the original Dell hard drive and installed Windows 7 to it. I thought, “Great! No problems!” I jinxed myself. My dumb ass installed all of the drivers AND utilities from the ASRock disc that came with the mobo. I managed to sully my brand new OS with Zynga and other bloatware within a few minutes of installing it. I would like to do a clean install of Windows so I can install the drivers only, but I can’t get to the boot selector! I can’t get to the UEFI, either.

On bootup, I can hit F2 or F11 and either one will just leave me with a black screen. That’s it. If I reset and let normal startup commence, it’ll boot to Windows 7.

I just think it’s odd that I don’t have any ASRock startup screen like the image I linked to above. Is this because I’m using old Dell hardware and it’s mixing stuff up?

More about : extreme3 gen3 access uefi boot selector install

a b V Motherboard
April 13, 2012 2:33:29 AM

Have you tried hitting the CLR CMOS button to reset the MOBO yet?
m
0
l
April 13, 2012 1:34:55 PM

raven2510 said:
Have you tried hitting the CLR CMOS button to reset the MOBO yet?


I did. Because it restored the mobo to all defaults, I had to reset SATA mode to AHCI. When I saved, exited and rebooted, I tried to go to the boot selector, but I got the black screen again.

Is there any real disadvantage to setting the SATA mode to IDE? I mean, would I really even notice anything different if I left it in IDE? Or would it be better to just reset CMOS each time I needed to get into UEFI or the boot selector (which I don't really anticipate doing very often once this is resolved)?
m
0
l
Related resources
April 13, 2012 3:36:37 PM

Solved!

The problem isn't the motherboard: it's my old Dell HDD. It's a Seagate Barracuda from 2007, so it doesn't support AHCI. So until I get an SSD, I'll need to reset CMOS once again, set the SATA mode to IDE and save up.

Once I install the SSD, I don't anticipate any problems.
m
0
l
a b V Motherboard
April 13, 2012 5:16:17 PM

Great, Glad you got it figured out.
m
0
l