GIGABYTE GA-X58A-UD3R BIOS Settings to achieve AHCI mode

Here is my problem. I am trying to flash new firmware onto my SSD and clean it. I have completely lost the Win7 Pro dvd's ability to see the drive. I am flashing it and cleaning it with linux OCZ utilities(they are great). I just need to set my BIOS properly so that I am in AHCI mode, not IDE. Does anyone have a quick link or listing of the settings...I need to make the changes. My rig specs are:

Mobo: GA-X58A-UD3R LGA 1366 Intel X58 SATA 6Gb/s USB 3.0 ATX
BIOS: ???
CPU: i7-950 Bloomfield 3.06GHz LGA 1366 130W
HDD: OCZ Vertex 2 OCZSSD3-2VTX90G 3.5" 90GB SATA II MLC Internal Solid State Drive (SSD)
OS: W7 Professional

Any help will get me closer to closing out my 5 day nightmare! But, I sure am learning alot.
3 answers Last reply
More about gigabyte x58a ud3r bios settings achieve ahci mode
  1. I have the same motherboard with BIOS version "FE". Enter the BIOS and select Integrated Peripherals. Then select ICH SATA control mode. Then choose ACHI instead of IDE.
  2. made the change and a couple of others on the sane screen down toward the bottom. Error occurred with the instructions above and attempted again after a couple of more changes to the BIOS co getting the sata controller switched to AHCI from IDE. I really am at a loss...but really want to flash the firmware with the error not occurring. The OCZ tool allows for a firmware flash in the IDE mode, but an error may occur. Anything to say about this possible way of continuing?
  3. u may need to use dispart tool in windows 7 os installation dvd.
    go to installation process and press shift+F10 .. then you will see command prompt to go on the disk clean and partition process.
    after that, you need to get preinstallation driver ready for ahci mode, if the disk can be detected well, there will be no need for preinstallation driver.
Ask a new question

Read More

Gigabyte BIOS Motherboards