ASRock Extreme4 Gen3 LAN Issue

Help me! I am going absolutely insane....

Last night when I came back to my computer it had "recovered from an unexpected error" - on review this was a BSOD.

The computer had been left doing nothing, literally no programs open just the desktop.

On review I had no LAN connection and Windows was displaying that the driver could not be found.

No problem I thought a quick reboot should fix it.....or not....

12 hours later I have tried all of the following and still have been unable to get the LAN to work;

- Reinstall of LAN driver from CD
- Reinstall of LAN driver from web (copied on USB)
- Different ethernet cable
- Reinstall of windows
- BIOS update to 1.2

I am going absolutely loopy trying to get this resolved, anyone got any ideas?

Thanks
4 answers Last reply
More about asrock extreme4 gen3 issue
  1. Do a system restore to the time before the BSOD and see if it comes back to normal.
  2. I already tried that before the reinstall of Windows with no luck
  3. Edit - Don't know if this helps but the light is orange on the ethernet port...

    I can't find it in device manager either to manually install driver (the netgear key is what I'm having to use at the moment), screenshot below;

  4. My PCI Soundcard has now also given up the ghost and won't detect.

    Looks like this is a MOBO HW issue.
Ask a new question

Read More

Motherboards LAN Computer ASrock