Sign in with
Sign up | Sign in
Your question

Hard disk running slow? Is it related to virtual memory?

Last response: in Systems
Share
May 3, 2011 8:06:01 AM

Recently, my computer startup is very slow, about 5 minutes to load all the stuff on desktop, Loading applications also slow. I have 465 GB of hard disk space and about 100 GB free space left, my RAM is 4 GB , using Windows 7 x64bit and saw my virtual RAM in task manager has 10 GB????!!! How can i decrease the virtual RAM OR Should I Decrease the virtual RAM?

Note: I have cleaned the whole PC, no virus or any malware, Defragmentation is done as well as cleanup, normally my ram usage is 1.4 GB at startup
(I'm using microsoft security essentials) (ALL latest updates from microsoft) (CPU usage in idle is 3%)
Please help, thanks.
Forgive my poor english, lol. :D 
May 3, 2011 9:05:50 AM

Do you only have 1 hard drive? If you have more than 1 hard drive you will benefit more from virtual memory if you put your page filing on a separate hard drive than what your OS is on.

To get to your virtual memory. Right click my computer > click properties > click advanced system settings > make sure your in the advanced tab at the top > click settings underneath performance > click the advanced tab at top > you will see virtual memory and a button that says change click it.

Uncheck automatically manage page filing at the top of the window > Tick custom size. Make initial and maximum size the same for whatever your going to set it to. I usually put mine on recommended.

Things could be different for Windows 7 though so someone could come along and correct me on this.
m
0
l
May 3, 2011 9:26:49 AM

Evan20x said:
Do you only have 1 hard drive? If you have more than 1 hard drive you will benefit more from virtual memory if you put your page filing on a separate hard drive than what your OS is on.

To get to your virtual memory. Right click my computer > click properties > click advanced system settings > make sure your in the advanced tab at the top > click settings underneath performance > click the advanced tab at top > you will see virtual memory and a button that says change click it.

Uncheck automatically manage page filing at the top of the window > Tick custom size. Make initial and maximum size the same for whatever your going to set it to. I usually put mine on recommended.

Things could be different for Windows 7 though so someone could come along and correct me on this.


I already have your configuration, but still same. :( 
m
0
l
Related resources
May 3, 2011 10:23:33 AM

Here's an image:

m
0
l
a b B Homebuilt system
May 3, 2011 10:57:45 AM

Make sure your harddrive is running in DMA mode and not PIO mode.
m
0
l
May 3, 2011 11:29:35 AM

Unolocogringo said:
Make sure your harddrive is running in DMA mode and not PIO mode.


Uh I'm not an expert on computers can you explain how to do or check that?
m
0
l
May 3, 2011 3:35:39 PM

bump
m
0
l
May 10, 2011 8:08:45 PM

To address your slow boot time. Have you checked your startup programs? Having a vast amount of programs at start up tends to slow it down.

Do you use windows default defrag or 3rd party?
m
0
l
May 17, 2011 11:11:14 AM

Evan20x said:
To address your slow boot time. Have you checked your startup programs? Having a vast amount of programs at start up tends to slow it down.

Do you use windows default defrag or 3rd party?


I checked the startup programs using msconfig, very little only, most is important to start eg. printer software.

I use smart defrag sometimes, and use windows defrag sometimes.
m
0
l
!