Sign in with
Sign up | Sign in
Your question

ECS G31T-M dropped to USB 1.0 :-(

Last response: in Motherboards
Share
April 16, 2012 1:23:02 AM

Greetings,
I have been using the ECS G31T-M for ~2.5 years, and USB 2.0 was working fine.
Recently, all of my devices started complaining that they were being plugged into a 1.0 port, and of course, could perform faster if they were used in a 2.0 port. :-(

I can't think of anything that changed that would have caused it.
My best guess is that I did open it up to blow the dust out using one of those compressed "air" cans.

My Env:
----------------
Win XP SP2
ECS G31T-M
Pentium D 915 (Dual core)
BIOS: 080014 06/29/2007
USB mouse, LogiTech C910 Webcam, iPhone, Canon camera, Cisco Flip

Things I have tried:
----------------
Front and back ports
Just a single USB device, directly into PC (i.e. no USB hub)
Re-installing the USB driver by deleting the current one in Device Manger for all 4 controllers, and letting it re-install
Verified BIOS is still set to Legacy USB Support == Disabled

Questions:
----------------
Yes, the BIOS is pretty old, but this used to work.
Is it worth upgrading anyways, even though I wouldn't expect it to help?
Is there a jumper on the MB which I might have blown off, causing it to use 1.0?
Any other suggestions on things to try?


Many thanks in advance!
Nate

More about : ecs g31t dropped usb

a b V Motherboard
April 16, 2012 8:26:30 AM

Going to be a tricky one, me thinks. :-/
Based on your OP, I would suspect the compressed air exercise might have loosened something. I regularly clean my systems with cans of compressed air, so you didn't do anything wrong on that front.
To my surprise this motherboard does have jumpers for USB power rating, which I suspect could have been blown off (I've never seen a jumper blow off before, but hey, there's a first time for everything.)
I suggest you look at your manual, but I see two jumpers, one for the front panel and one for the back, regulating the power. Look in Section 1, pgs 4&5 and section 2 pg 9.
Apparently, one test is to try to wake the system up with a mouse (USB). If you could before, but now can't, that power jumper could be the culprit

Also, just take good look, with lots of light (a flashlight even) to make sure nothing else is knocked loose (check both mobo power connectors, USB front headers, etc).

BIOS upgrade? No, not necessary here. If it was working, and now not, a BIOS upgrade isn't going to help.

If you're still stuck, I'd redownload ECS' chipset driver and install from that (vs through the device manager like you did before).
Good luck. Let us know how this works.
May 5, 2012 10:20:01 PM

Finally got back to this issue today.
I actually found my MB manual!
Opened it up and verified both Front and Rear USB power headers have a jumper in the 1-2 position.
I also downloaded the ECS MB chipset drivers, restarted, and still no joy.
e.g. Webcam complaining that it is "connected to a Full Speed USB 1.1 port", so can only do "small" resolution.

Not sure what else to try besides buying a new MB. :-(

Thanks for the reply,
n8
Related resources
a b V Motherboard
May 5, 2012 11:43:14 PM

Imo you just need to update Driver [ USB + LAN + CHIPSET ] + BIOS
a b V Motherboard
May 5, 2012 11:57:06 PM

Mechanical damage can lead to components becoming desoldered from the mainboard and no longer having reliable electrical contact it might be possible because of AIR COMPRESSED CAN
May 21, 2012 3:29:55 PM

Minor update... I noticed over the weekend, my video capture card (IEEE 1394) wasn't recognized in Device Manager. It has worked fine for many years, but I haven't used it in quite a while. I moved it to my son's computer and it worked, so the card is fine.
Seems like another vote to replace my MB.
Guess I'll update the BIOS just for grins, and if/when that doesn't work, it'll be time to start shopping. :-)

n8
May 23, 2012 1:15:43 AM

Wow, didn't expect that...
things are working after flashing the BIOS with the latest version! :D 
i.e. No more complaints about "this device could perform faster", and I am able to use my Webcam at 1080.

In retrospect, I should have tried resetting BIOS back to default first as that might have actually been the ticket after the upgrade.

Either way, things are working now, and I don't need to replace the MB right away.

Thanks for the suggestions!
n8
!