Sign in with
Sign up | Sign in
Your question

can't play Battle for Middle Earth on router

Tags:
  • Routers
  • Switch
  • Linksys
  • Cable
  • Networking
Last response: in Networking
Share
January 18, 2005 5:13:18 AM

hi, I can't play online with my Linksys BEFSR41 CABLE/DSL router/switch combo.

I read in a tech support forum that routers do cause the problem but only supplied a solution for D-Link routers and a USRobotics router.

More about : play battle middle earth router

January 19, 2005 10:49:29 PM

Are you haveing problems connecting to a game or hosting one?

You may need to forward some ports from your router to your computer. If that is what they are talking about in their tech forums it doesn't matter what router you have. Port forwarding is basically the same for all make and models.

<A HREF="http://www.folken.net/myrig.htm" target="_new">My precious...</A>
January 21, 2005 1:28:46 AM

I am unable to even reach the Login screen because before that happens, a message appears:

Unable to establish a connection with Battle for Middle Earth servers.

What do you mean by forwarding some ports from my router to my computer?

-------------------------------------------------
Athlon64 Newcastle, 2800+, 640KB Cache, 1800 MHz
MSI K8M Neo-V, VIA K8M800 + 8237 chipset
Sapphire Atlantis Radeon 9600 256MB
Related resources
January 21, 2005 4:13:23 PM

Hm.. I checked out that support page on the EA games site and saw what you were talking about with the usrobotics and dlink routers. It claims you don't need to do any port forwarding to make the game work on other home routers. Just incase you happen to be an exception they do list the ports needed: UDP ports 8088-28088
Just find out your computers IP by going to a command prompt and typing ipconfig. Then go into your routers config and find a section called port forwarding. There should be an option to add a range of ports (like 2 boxes separated by a : or something). Then just enter that range of ports (if udp is an option choose it) and tell them to go to your IP.
There is also a little thing at the bottom of the EA games support page: Additionally, if you are using a combination of a cable modem and a router, you should contact your ISP/cable provider in order to disable your modem's built-in firewall.
If that applies to you it might be worth looking into. You don't need another firewall in your modem if you have one in your router :) 

<A HREF="http://www.folken.net/myrig.htm" target="_new">My precious...</A>
January 22, 2005 3:59:03 AM

thank you very much for your help.

<img src="http://img.photobucket.com/albums/v216/sonofangron/port...">

I found the port forwarding page, but I don't know what to put under "application".

-------------------------------------------------
Athlon64 Newcastle, 2800+, 640KB Cache, 1800 MHz
MSI K8M Neo-V, VIA K8M800 + 8237 chipset
Sapphire Atlantis Radeon 9600 256MB
January 22, 2005 4:12:19 AM

That is just a name you can give the range to remember what it is. Just put LOTR or something, anything goes.

<A HREF="http://www.folken.net/myrig.htm" target="_new">My precious...</A>
!