Sign in with
Sign up | Sign in
Your question

Sabertooth 990fx + corsair force 120gb ssd

Last response: in Motherboards
Share
April 18, 2012 3:10:28 AM

hey guys

i was hoping someone would be able to help me out with some issues im having with my pc. just did some upgrades from an older mobo to a sabertooth 990fx which had no problems that i could see. However, yesterday i reformatted and put in a 120gb ssd. And from then on it just seems my computer has become quite unstable. I was getting BSOD, random crashes in BF3, chrome and skype as well as issues with other programs not working properly. freshly downloaded instals coming up "corrupt". I took out my old hdd, have done several fresh OS instals ( with reformat) and still no improvement...

Was really hoping someone would be able to help me out as im not a very computer savvy person. I have looked on here a little bit but as i said im not to tech savvy... would anyone recommend a bios update? or is there any knowns conflicts with ssds?

any help would be really appreciated as i really wana get this all sorted out before GW2 comes out :p 

a b Ĉ ASUS
a b V Motherboard
April 18, 2012 3:19:26 AM

Hey there mate , you could have a faulty SSD , Ive had to RMA the exact same one twice. also if they arent set up right they will cause a lot of problems.
Go into your bios and make sure you have set the hardrive mode to ACHI and not IDE.
Reboot and see if you still have any problems.
Are you getting freezing or blue screens?
m
0
l
April 18, 2012 3:57:37 AM

ok upon changing it to ACHI, i rebooted and i got a blue screen on the windows start up logo... any suggestions??
m
0
l
Related resources
April 18, 2012 4:08:30 AM

just throwing this out there.. the fact that im using a 500w power supply, could that have anything to do with it. however it was always stable with the old sata hdd

I have a AMD phenom II x4 955 BE
Sabertooth 990fx
4x2gb ram
nvidia 560
corsair force 120gb ssd
m
0
l
a b Ĉ ASUS
a b V Motherboard
April 18, 2012 4:10:24 AM

You may have a faulty SSD. Is it brand new?
Hook up another hardrive and install windows and see if your pc has any problems , make sure you return it to IDE in the bios.

Now , with the SSD , your options are to either RMA it or try to install it again, format/secure erase it , update to the latest firmware using the Corsair Force 3 Firmware updater. Make sure when you install the drive that you return it to ACHI in the bios.
Wich can be found here http://forum.corsair.com/forums/showthread.php?t=100162

The drive needs to run on ACHI , if it doesnt it wont work proerly, see if you can boot in safe mode as once you choose the ACHI option in the bios , windows will install the ACHI drivers upon reboot , keep trying to reboot with ACHI enabled for these files to install.

Follow the instructions perfectly and hopefully you might have some success if not you will have to return the drive unfortunately. These drives are notorious for issues. Two of mine died.
m
0
l
April 18, 2012 5:16:46 AM

ok i think i may have solved it thanks to your help. ive updated the bios and read up on the link you gave me, and reenable achi in the os registry not just the bios. so ive done all that and now i can actually boot in achi which is a first. i guess now i just need to test some games/programs...
m
0
l
a b Ĉ ASUS
a b V Motherboard
April 18, 2012 5:26:01 AM

Awesome , that guide is the best, you dont realise how complicated an SSD can be till you read something like this. Im glad it worked out , usually windows will install the ACHI drivers for you upon reboot , but forcing it in the os registry sometimes has to be done, without the AHCI drivers the SSD is useless.
Goodluck , Im happy that the guide helped you out, now enjoy the speed of your new SSD, Download this and benchmark your SSD, its free and easy to use, let me know how you go.
http://www.attotech.com/products/product.php?sku=Disk_B...
m
0
l
April 18, 2012 5:38:50 AM

i got 473mb write, 542 read so i guess that is almost full speed :) 
m
0
l
a b Ĉ ASUS
a b V Motherboard
April 18, 2012 6:53:39 AM

Thats awesome results, congrats :) 
m
0
l
a b Ĉ ASUS
a b V Motherboard
April 18, 2012 6:54:47 AM

Make sure you disable Defrag, defragging reduces the life of your SSD.
m
0
l
April 18, 2012 7:36:18 AM

mmm ok well things still seem to be troublesome =/, bf3 is still crashing as well as the fact that i cant install anything as i seem to get .cab (cabinet) file is corrupt issue...
m
0
l
a b Ĉ ASUS
a b V Motherboard
April 18, 2012 8:28:04 AM

Ok sorry to hear that, did you do a firmware update?

If so back everything up and follow that guide I posted , you might have to reinstall windows again :( 
m
0
l
April 18, 2012 9:25:14 AM

yea ive done the firmware update. :(  from what i can tell the bf3 crashes are because i only have a 500w power supply.. but the fact that i cant install anything without getting .cab file errors has me stumped :S
m
0
l
a b Ĉ ASUS
a b V Motherboard
April 18, 2012 11:10:45 AM

500 Watts is plenty for a 560 , what brand is it?
Do you have another hardrive you can use for a storage drive?
If so try installing BF3 on that and see if it works.
m
0
l
!