Sign in with
Sign up | Sign in
Your question

Computer won't boot with 5850, works with old graphics card

Last response: in Systems
Share
May 7, 2011 10:33:28 PM

System:
Asus P7P55D mobo
core i5-750 cpu
2x 2gb corsair ram
gs 600 corsair psu
5850 radeon
2x HDD

I recently purchased a 5850. Ran awesome for approximately 2 weeks with no issues.

Today, after pressing power button, all fans come on, but nothing appears on monitors (no bios or anything), also no "startup" beep comes from my computer. Tried unplugging everything, tightning graphics card to no avail.

I pulled out the 5850 and put in my old graphics card in the same PCI-E slot, the computer booted up immediately and was fine. My old graphics card does not require any 6pin power, while the 5850 requires 2 6 pin connectors.

Then I plugged the 5850 back in again to try and got the same problem: nothing on monitors, no startup beep.

Not an expert.... my assessment this means either:
a) PSU is having problems and not providing enough power to 5850 (replace PSU)
b) graphics card is hosed (replace graphics card)

Any ideas for what the problem may be and how I can troubleshoot this further before trying to return parts?

Thanks!
May 8, 2011 12:06:07 AM

did you tried without putting power pings to gpu
there should be a red text "you forgot put pins kinda "
atleast you can learn your gpu working or not
a b B Homebuilt system
a b U Graphics card
May 8, 2011 12:45:33 AM

Which 5850 did you get? Some of them require 2 6pin and others require 1 6pin and 1 8pin. If it's the later you might have under supplied it for a few weeks and killed it. Either way it sounds like the graphics card died. I wouldn't expect a corsair psu to fail and a 600W should easily be able to handle it. Is it still RMA able?
May 8, 2011 2:31:30 AM

The exact video card is XFX HD585XZAFC Radeon HD 5850.

It has 2 6-pin connectors on the back that I've always had fully connected.

I bought it less than a month ago, so I can return it to the reseller still.

Any other ideas or troubleshooting suggestions?
!