Sign in with
Sign up | Sign in
Your question

5770 crossfire help

Last response: in Graphics & Displays
Share
March 2, 2011 8:11:33 AM

When I run CrossfireX my second video card is always running at 0% clock and mem speeds as well as the fan at 20% even when I adjust it to 70% it goes back to 20% and it seems when in crossfirex that only one GPU is working not the other but CCC says its in CF...How do I fix this?

System:

Intel Core 2 Quad Q9550 @ 2.83 Ghz
8GB Kingston HyperX DDR2 Ram
MSI P45 Platinum CrossfireX Motherbord
Silverstone Stryder 850w PSU
2x XFX 5770's CF

More about : 5770 crossfire

March 2, 2011 8:21:56 AM

Gpu 2 runs:
37c
850Mhz core
1200 Mhz memory
Fan 70%

Gpu 1 runs:
0c
0Mhz core
0Mhz memory
0% fan

Its like crossfire isn't enabled but it is
m
0
l
a c 172 U Graphics card
March 2, 2011 8:36:12 AM

What game are you trying to play? Even if it wasn't being used it should still be at its 2D clocks, so having zeros across the board might just be a reporting error.
m
0
l
Related resources
March 2, 2011 8:38:59 AM

Battlefield Bad Company 2 and Crysis but games aren't the issue I am trying to get GPU 1 to run and it just resets clocks and fan speed just like its acting as if its not in crossfire but it is
m
0
l
a c 172 U Graphics card
March 2, 2011 9:30:29 AM

I asked about the games because not all games support CF. The best example is GTA4 which doesn't at all. Even if the drivers report CF mode, you will only use one GPU because that's all the game is programed to use. In this case because card 2 isn't being used, I could see it reporting 0% usage.

I believe both of those games support CF, so its something else. I'd try removing the driver, run driversweeper, and then put one of the better CF drivers on. 10.1?
m
0
l
a c 106 U Graphics card
March 2, 2011 2:30:11 PM

The second card shouldn't be 0Mhz on anything. Test each card individually. It sounds like the second card may not be properly installed or just isn't working all together.
m
0
l
a b U Graphics card
March 2, 2011 4:47:29 PM

Yeah and crossfire will work on games that don't support it, but it will work badly, performing worse then a single card running. You have to turn it off manually before playing a game that does not support it. Anyway, uninstall the cards, then run driver cleaner to make sure the video drivers are wiped completely. Take them out, reseat them and the Crossfire bridge. Boot up and reinstall Catalyst, then install the Catalyst Application Profiles. Restart, make sure crossfire is enabled. Then run a few test like Dirt 2's benchmark, 3D Mark Vantage or 2k11, and run fraps while doing a few game sessions of games known to work in Crossfire. Make sure to record your results in the Fraps log during the game sessions. F11 should do it during gameplay, and you can check the Frapslog in Fraps install folder.

Now repeat all the above, but with Crossfire disabled. On the game sessions, make sure to try to play the exact same areas you played before. Also, don't have Fraps record the fps to its log until normal gameplay begins. Story scenes and loading screens fps will mess with the results otherwise. When you have done everything, compare all the results. When you are doing this, be sure to run the games maxed out as much as possible, at the highest res you can run on your monitor.

Oh yeah, and if the card is just showing up as idle/zero in the AMD Overdrive section of CCC on your second card, that could just be a fluke. If everything is working fine in gameplay, then just ignore it.

m
0
l
March 2, 2011 5:56:19 PM

Another problem I have is the first card idles at 35c and the second 46c so the one that's not working is hotter than the other so if I could just get the fans to work on both I should be fine. The other issue is I had previously two 4870's in crossifrex and no problems but when I installed these two 5770's it don't work the same so I think it has nothing to do with CF or CCC.
m
0
l
a c 125 U Graphics card
March 2, 2011 6:31:18 PM

Something overlooked - If you're reading those numbers in CCC, then that's the problem. Who knows why, but CCC will report the 2nd card like that. Use GPUZ or MSI Afterburner for more accurate info.
m
0
l
March 2, 2011 7:56:26 PM

I fixed the issue...I called XFX and asked them and they said since the driver update 10.4 was released they added a feature for a card that doesn't use a monitor to go into low power state when not in a 3D application so its fine now. So when I launch a game the second video card turns on.
m
0
l
!