Sign in with
Sign up | Sign in
Your question

Only half my 16GB of ram works, other half is hardware reserved.

Tags:
Last response: in Memory
Share
April 22, 2012 2:19:26 PM

HI,
sorry if this is in wrong section, I did try to get it right! Also I was not sure if this was a mobo or ram issue so have posted in both sections, if this is wrong please let me know and I am sorry for my mistake if one has been made.

Here is my specs and issue/s.

I got a Asus P7P55D-E Motherboard. HERE

My Other specs are here;

Intel I7 870 Cpu. HERE
16 GB of corsair memory 1333 speed ( I have 4 banks with 4 GB stick in each ) They worked fine on last computer. HERE They are all from there.
Cooler master case and psu, HERE
XFX Radeon HD 5770 - Graphics adapter - Radeon HD 5770 - PCI Express 2.1 x16 - 1 GB GDDR5 - DVI, DisplayPort. HERE

I got a sata 6.0 500 WD HD with O/S W7 ultimate 64 bit on.
I got a sata3 seagate barracuda 500 GB and a seagate external momentous 500 GB for back up.

And I got the arctic cooler for the cpu.

all temps are great and fans are running great as-well.

I used the asus memory finder tool ( not there pdf's ) to find if my memory works and it is there and so is cpu.


CPU says it can run 16 GB and also the board can run 1333 speed memory.

Now computer/right-click and properties shows I have 16 GB installed but only 8 GB usable.
Resource monitor shows that 16 GB installed but half is reserved for hardware.
CPUZ shows all my memory and that the latencys and voltages are right.
CPUZ shows 16GB as said and the spd shows 4 gig in each slot.

I just dont get it.
I have not overclocked any thing yet as wanna get system working right 1st.
I like 16GB because programs like After Effects uses a lot of ram and I use that program and maya and photoshop etc etc, I like to have these programs open and at hand, hence the 16GB.

The whole new PC is new except I used the cpu and memory and gpu from old computer ( well I say old but it was basically brand new but free and not what I wanted,.

Asus have emailed me with suggestions and I have done every thing they asked and still no good.

so does any one know a way round this?
Maybe hardware reserved memory can be moved to be used as normal?

So I thought that maybe at 1333 speed I cant have 16GB installed on this board so used other sticks of ram with same latency and voltage to replace two into two of the banks, removing the 2x4 GB sticks. But that just got me to 12 gig installed and 6 gig usable. I used 2x2 gig gskill. I also was careful to keep the 2x4 GB sticks in right banks and 2x2 gig in right banks. When all 4x4 GB sticks are installed I dont think it matters as all same but I have still tried to move them from bank to bank, no joy
so no matter what goes in only half is being used,

Asus have given up on me and said contact seller, which I have, waiting reply but though I would try here as you are mostly really clever.


So if I can give more info or you need more info just ask and if not please can you help me?

regards,

Tom

PS: What hardware would need to use 8 GB of ram? I no my GPU card ( listed above ) uses hyper-memory but never really needs it as I have a GB ddr5 card. And was never an issue on my last PC, which I say again was not old but did not have features that I wanted, like;
usb3
sata 6.0
O/C features
crossfire ability, I got the lower profile gpu card for this reason ( off subject ) as the low profile gives better cooling ability and does not sit so close to each other as not as fat. But that is for me to think about and nothing to do with this.
April 22, 2012 3:52:45 PM

Do you have windows 7 home premium or home basic because basic is limited to 8GB while premium is limited to 16GB.
April 22, 2012 3:55:07 PM

Hi I have windows 7 ultimate 64 bit, legal and activated.
Related resources
April 22, 2012 4:58:48 PM

Sorry I'm stumped :/ 
April 22, 2012 5:25:30 PM

Thats OK, this is a hard one, I'm no expert but I know my way round a PC and O/S and not bad with a bios. Dont use raid so no good at that, lol.

Thanks any way.

I have searched the internet some what and have seen same issue with other people who have purchased this board. Most
have been sorted by the msconfig/boot/advanced and un-check the memory box. Well I have checked and unchecked and even tried changing number but none worked and just went back to proper amount and un-checked.

I have tried changing voltage/latency, tried changing values in cpu all sorts but to no good.

tried turning IO level up off and on and switch between the options of: USB3/Sata 6.0 and also disable, which I thought bight of been issue where the increased bandwidths have been stealing memory or keeping it safe in hardware reserved, but no it was not that. So just put it to sata 6.0 as my boot drive is sata 6.0 and I have no usb3 hardware....yet! Seems you have to have one or other and it affects pci slot. But that's another story.

But some Google storys have found no answer.
I would change memory if I new for definite that it was the problem, maybe i need a higher speed? But my CPU does take 16GB at 1333 speed so I dont know on that one, but I will buy if needed.

And I have tried different memory at lower GB but that did not help.
Have cleaned with rubber ( as advised bu asus ) the pins on memory....but my O/S DOES see 16 GB just something is stopping me from using it all and reserving half of it, but for what and can I move hardware reserve3d from there to free memory?
or is there another answer.

would be great if we could solve this one as it is a common issue and would help a lot of peops.

Cheers.


a b } Memory
April 22, 2012 6:37:52 PM

Resemble pc might work or try to 1st 4gb then check system then 8gb then 12gb and last 16gb (each time check system ram and dont remove already installed ram) im not expert but try this.
a c 90 } Memory
April 22, 2012 7:25:55 PM

check to see what windows set up for windows swap file..it could have glitched and set it self up to large. open up tast manger and see what using the ram...it could be a virus or a damaged window file.
April 23, 2012 9:08:06 AM

OK,

1st I will try putting the sticks of ram in one by one to see if that helps.

I have set my page file to boot = 1000-1000, ( min and max ) I read up on it and was told many times to keep it low on boot drive.
I then have another HD that I system manage file page.
All other HD's and partitions are set to none.
This is how I had it set up.
I had it set like this because i have 16 GB of ram so page file is not to important as if I had 4 gig for example.
I did change it to system managed for all drives, no help after restart.
I also set each partition low and high to test but no joy.

Im gonna try put a screen shot of resource monitor showing 16GB installed but half being reserved for hardware.

basically my PC is seeing all my ram, cpuz reads it all right and it is right latency and voltage and each slot is correct and total is right.
it is just this issue as to WHY is resource monitor reserving half of it.

I have been thru mobo manual so many times and done every thing in bios to try help.

Right lets get some images in.





gonna show just one slot but believe me they are all same in spd in cpuz;


Lastly this printable version of WEI ( think that's right way round, lol ) shows 16 gig installed. also would of thought my sata 6.0 boot drive might of gone up in score as it is set to sata 6.0 and right cables and slots on mobo but thats a different issue. This shot only confirms that I DO have 16GB installed, I think we have that sorted now we just need to know why it is being halved and 8 GB reserved for hardware??? ?




Thanks for all help.
April 23, 2012 9:13:32 AM

sorry for double post but nothing is eating ram like a virus. I use avast/spy-bot ( for scanning and also ad-aware for scanning ) and I have no-script on browser, or in browser, lol. I have gone thru every process and they all are good.
a c 139 } Memory
April 23, 2012 9:17:34 AM

Hi there Tommy,

Your motherboard has two standard PCI slots. These are usually accompanied by a BIOS option to remap the PCI addresses above the physical memory space. In 64 bit systems having this option disabled will limit the size of your physical address space. Please take a look in your system setup, it should be under the chipset settings somewhere
April 23, 2012 9:24:34 AM

haha,
I was just gonna post a question about pci and if that could help.
this is what I was gonna post;

On my other system (n which is now in pieces ) I had same set up but the mobo was an acer crap one, but had same gpu card and same ram and all worked fine, so I cant see it being the hyper-memory/shared memory on card that is eating it plus numbers dont match and also I have a GB dedicated so wouldn't need all that hyper memory any way. I haven't got crossfire in action as only one card at mo but maybe the fact that it has 2 slots for crossfire means it is saving ram for that? So could I try disabling the space pci slot that would be used in a crossfire config? Just an idea.


but I will look for what you said.

cheers.

Tom
a c 139 } Memory
April 23, 2012 9:36:54 AM

PCIe doesn't cause any problems like this, this is extremely characteristic of old and often inflexible legacy systems. On old 32 bit systems the Operating system designers would be well aware of the fact that the physical memory space would often overlap with reserved system memory or memory mapped IO. This is why 4GB of RAM in a 32 bit Windows installation never actually shows up as 4GB, that space has to be shared with memory mapped devices and system reserves. When the memory space was expanded using PAE this problem was simply shifted out, resolving it partly. When it was expanded properly using AMD64 and EM64T some problems surfaced again and BIOS workarounds were necessitated in order to maintain compatibility.

On older operating systems (especially those without PAE) the PCI IO addresses (amongst others) still need to be within the 32 bit address space, thus necessitating that some physical memory be non addressable. On newer systems they can be moved above the physical address space automatically. Unfortunately, the kernel capabilities of the OS to be loaded isn't known until after all of this is set in stone.
April 23, 2012 9:56:09 AM

Hi Pinhedd,

I have done what you asked and tried it with no remapping which put 12 GB in hardware reserved and then put it back to enable and back to how it was, 8 GB usable and 8GB hardware reserved. I also tried a few other things but to no avail.

Im totally at a loss here.

Ive tried all that asus asked.

ill try the ram stick one by one later.

thanks for help but still need this solved.
April 23, 2012 10:02:31 AM

sorry for double post.
but every thing on new build is new.
My mobo is supposed to be quite good.
my case and power is good.
my ram is supposed to be good.
my gpu card aint too bad.
my hard drives are decent.
Im not a complete idiot when dealing with pc, but bios im still learning as I normally buy acer crap, but I have learnt a lot with this new system and tried to get the best my money can buy.


now I dont know whether to buy new ram or mobo, or maybe this is a simple answer were missing, well more me missing.
I even got a good cooler for cpu and got good temps and fan speeds.

gotta go for an hour or so so will see if any other advice has been given when I come back.

thanks so far.
a c 139 } Memory
April 23, 2012 10:05:29 AM

That was my suspicion, that it would bring it back down into the <4GB range but I wasn't sure. On my old desktop (Asus P5QPro Turbo, P45 chipset) it would cut it down to like 7.2GB or something nonsensical like that.

Here's another thread by someone with the same motherboard who had the same issue and solved it by reseating the RAM

http://www.silentpcreview.com/forums/viewtopic.php?t=59...
April 23, 2012 11:44:18 AM

Hi,
thanks for the info and link.
thing is I had a a acer m5910 that I had 16 GB ram in and all usable ( acer got it wrong when saying they accept only 8 gig as in there service guide and pc wizard all said 16 GB was cool ) so I had 16 GB of same ram running sweet, that was 64bit home premium.

So cant see it being a O/S issue.

I saw some one int hat topic say increase imc voltage, but to what. My ram voltage is 1.5v but imc voltage I have no experience with so not sure what I should put it at.
I have also tried increasing my ram to 1.65 voltage but it did not help and cpuz still only saw 1.5 on each slot.

So if a suggestion for imc voltage increase can be made to me that would be great peops.

Im also gonna loosen off the heatsink so it is not to tight as I saw that could be a issue as to tight might bend socket, so mine is an arctic cooler so will loosen screws a little, they are not tight just I tightened them till they gripped, but will go looser and check pins but new board shud be ok.

I also thought that maybe as my ram is 1333 speed that could be the issue but the specs fro board does say it can handle 16 GB and my cpu says up to 1333 speed so cant go higher any way. XMP wont work on mine for some reason, I can turn it on in bios but get no options, they are all greyed out so I have other options like auto/dohp ( or some thing like that ) and also xmp ( which I just told ya about and another i cant recall right now but none have helped so far.

Ill try taking board out and starting again making sure that all pins/screws are in right-then make sure cpu heatsink cooler is not to tight-check pins-insert ram one at a time making sure to use the right slot 1st.
and if I get advice on imc voltage ill try that also.

see I opened after effects, which some of you know is ram hungry and it only used 8 gig, it did not steal some hardware reserved ram like that topic said it might, ill try again but didn't have it last time, so it aint like the reserved ram is available if needed.

be real nice if we could move ram from reserved to free and vice versa but so far seen no way of doing this and I have googled this for hours.

cheers.

Tom

PS: please give me some advice on imc voltage before I touch it as dont wanna mess system up.

April 23, 2012 12:00:11 PM

Just a quick thing I need to point out.

I always test after effects with a full HD 12 second video in 32 bit mode.
Now with 8 gig I normally get to 8 seconds but im now getting to 12 seconds and fast as-well.
This is confusing as task manager shows only 7 gig being used by AE ( using open gl no multi processing )
resource monitor shows no ram being moved from reserved to free.
Its like it is using 7-8 gig to ram preview the 32 bit mode full HD video but is actually using all my ram as on two other machines I never ever got to 12 secs with just 8 gig.
so some thing is happening.
maybe the hardware reserved is also being used to render the video when ram previewed as I am using open gl and that does share memory even tho it also is 1 GB dedicated ddr5 card.
bit confusing but see,ms like although only 8 gig is shown to being used it must be using more to render that video as it never would with just 8 gig.

hope that makes sense and I might be able to live with it as is if that is the score, meaning free memory will be used when needed and extra will be taken from hardware if needed on top although it doesn't show like that in resource monitor.

ill keep testing and see what happens.

but more advice is always welcome.
a b } Memory
April 24, 2012 6:27:58 AM

It seems like you tried many things but aint work ok
go to bios make changes default after that reboot system see what you got
if same issue your facing then

I have done what you asked and tried it with no remapping which put 12 GB in hardware reserved and then put it back to enable and back to how it was, 8 GB usable and 8GB hardware reserved.

i don't know where you did that but go up there again if there's option of defaults choose it.Or as you said your 1t time its 12gb hardware reserved and then you put it back enable after you got 8gb maybe there's something that need's to be fixed im not expert...but let it try.
April 24, 2012 11:35:44 AM

so your saying set my bios back to default.
and also that there might be a memory remapping issue with this board?

Well I have not really done much in bios that I have not set back to default so it wont hurt to have settings at default, so will try it.

But like I was trying to hint at above it seems like my computer uses as much memory as needed even if it is hardware reserved, so that being the case I dont know if I have an issue.
April 24, 2012 11:38:07 AM

sorry, I meant to add that the only option I get is enable and disable for memory remapping.
also I dont think my memory has xmp because when I enable that feature in bios all the options I should get are greyed out and not able to touch them. Just thought I would mention that as-well.

cheers.

Tom
April 24, 2012 11:55:57 AM

I am having the same issues as you with my MSI P55GD65 motherboard, i5 750 CPU, HD5770 graphics, 12GB memory (2x4GB and 2x2GB sticks running at 1333). The odd thing is that it was working fine for months. Now it is showing 12GB installed 5.99GB available. I don't know when this started exactly: Last week I updated my BIOS and installed an SSD and did a clean install of Windows (64bit HP) and I don't know after which task this problem started - I mean how often does one check these things in task manager / System settings?

I'm going to try resetting the BIOS to failsafe defaults tonight to see if that helps.




P.S. There are number of people with different mobos seem to have this issue and posted threads about it over the interwebs and all the threads are just people asking whether they're using a 64bit CPU or OS and offering no help at all. Glad that this thread has some useful information in it!
April 25, 2012 9:38:11 PM

It might be a software situation relating to RAMDISK. Example, I have 16gb, but 6gb are reserved in a ramdisk that acts as a virtual drive, that also allows me to use as a page file, or temp folder. Even though I have 16gb ram, only 8gb are available for use. According to task manager, I have 48 processes running which normally uses about 1700mb, and if I add that with my 6gb ramdisk it shows I'm using about almost 8gb.

Check your software if you have anythang that claims to "optimize" your system. Go through the options and check to see if anythang reserves or sets aside ram. Disable this option, uncheck, or whatever you have to do, and see if this works.
April 26, 2012 12:33:24 PM

Thanks for your advice I will try all this.

T
April 26, 2012 2:49:54 PM

I have removed every thing that can alter system but still getting same result.

BUT...

I always test ram in after effects as it is an hungry program.
normally with 8 gig I get 7-8 secs of full HD of a 12 sec movie in 32 bit color mode.

So I tried it in 32 bit and it flew thru it no problems, taks manager reported only 7 odd gb being used but it must be taking ram form hardware reserved to the video to run to 122 secs, it will not run that far with just 8 gigs so it is getting more ram from some ware.
I then made a duplicate of video and set comp to 24 secs and made a 24 sec pre comp of a full hd movie 32 bit colour mode and 24 secs long, I have never ever been able to run past 13 secs with 16 gig installed. now I got the whole 24 seconds run in 32 bit mode full HD...as keep saying.
so AE is really the only program that I need a lot of ram for and it is using the ram ( 16 GB ) I got better than ever before on any other pc I have had.
Not sure why it is set up like this but it is working better than I want, so I gotta be happy really!

when I am running the video resource monitor changes not regarding hardware reserved so no clues there but task manager gets to 7 odd gb and then stops and then some thing else is taking over and adding more ram to the video ram preview so all my 16 gb must be being used.
and for it to run 24 secs at full hd and 32 bit colour mode is some thing my other pc's with 126 GB never could do, 12 secs was max on them.
so I am happy because I can do what I want to do now.

Im guessing where I use open gl in ae the hardware reserved ram is helping the open gl to ram preview the video and I suppose the better mobo, cooler etc etc is boosting it even further than on older pc's with same ram.

so I am hoping problem sorted.
why it is working it like this I dont know.

but it is working and any ram I have and need is being used I just dont understand why and how, but hey?

cheers all.
May 11, 2012 5:20:01 PM

I have an absolutely same problem with my Computer, there are only two RAM slot work will. If you solved it plz let me know.
thanks alot!
May 12, 2012 4:46:20 PM

Of course, I have checked all 4 of my slots and they all work, the computer recognises all 16 gig and so does cpuz/pcwizard etc etc but for some reason half is being reserved.
But like i have said it does seem that I am getting the full 16 GB's when I need it, so I'm confused fro sure.

cheers.

Tom

PS: Hope you also get sorted with your problem, and if you have not then start your own thread as you might get a better response as this topic is pretty old and dead'ish, lol.
January 11, 2013 11:19:12 AM

enter the BIOS on your system and go to the advance tab, enable remap feature! It worked for me.
!