CLOSE THREAD. SOLVED.

Build:

ASRock Z68 Extreme3 Gen3
EVGA GTX 550ti Fermi
Antec HCG-750w
Intel i5 2500k
CORSAIR Vengeance 8GB (2 x 4GB) DDR3
Westen Digital 1TB HDD


At first I didn't know where to put this issue, GPU or Mobo, but I figured out that even the onboard display does not work. I can boot the computer up, everything except the display works fine. As soon as it boots I can see the BIOS screen for about half a second, then it goes black. I can unplug/plug my DVI cable over and over for more half second glimpses, but that is definitely not an optimal fix. Can anybody please help me try and fix this issue.
4 answers Last reply
More about close thread solved
  1. I would swap out the DVI cable first if you are using the same cable, sounds like a shorted cable off hand.
  2. Forgot to mention that that was the first thing I did.
  3. Have you tried removing the GPU and just running it from the Onboard?
  4. Yes, as stated in the OP. But I figured it out, and it ended up being a problem with the monitor itself. What luck eh? Good ol CRT monitor saved the day. Time to figure out how to close this thread.
Ask a new question

Read More

ASRock Motherboards