Sign in with
Sign up | Sign in
Your question

Nightmare with the sabretooth 990fx AM3+

Last response: in Motherboards
Share
April 24, 2012 1:54:52 PM

Hey all,

Okies, I just bought all the parts to build my new machine, I'm using some from the others around here, heres the spec of the machine and then I'll describe my issue,

New- Asus Sabretooth 990FX
Old one- AMD Phenom II x2 BE 555 can unock cores 0,1,2 and oc to 4.2Ghz(stable on prime95 for 8 hours on my ASrock board)
new-16gb OCZ Obsidian 1600 9-9-9-16
new-750w OCZ ZT fully Modular
new- Monolith Full Tower Case
new- 3 x OCZ agility 3 256gb
new- 3 x momentus xt 750gb
new- 2 x baracuda 2tb
new- BD drive rec
new- OcUK Tech Lab - V12 Watercooling Kit 360 on cpu -
old- Gigabyte gtx 560Ti 1gb super overclock 3 x sli

My problem is this, my phenom is an old cpu and I love it, so I'm reluctant to swap it out, although the fx 81 looks tasty. When I build the system and did a dry test boot (no drives or cards just the psu and M/B with ram 1 stick of ram and cpu with cpu cooling block, the CPU led on the M/B lit and stayed lit, I tried powering down, and clearing the bios by hoping the jumpers, 1- to 2-3 then power up and and down reset to 1-2. I tried, reseating the cpu and re-apply AS5, i tried switching the ram, I exhausted everything I know and thinking of an RMA to dabs, I know it's not my cpu or ram as they work on another build. I've triedout of case booting, in case booting, dry and wet cooling, changed psu from my ocz 750 to a corsair 550w gold.

Is there any tricks to the sabretooth? besides throwing out the window!! This realy sucks, I got this little voice in my hed saying it's a DOA, but a louder voice saying ASUS would never do that to me lol.. Any suggestions would be great

thanks all


April 24, 2012 2:32:58 PM

The CPU LED stays on... why is that an issue? I have the same board with a x3 720 o/c to 3.4. I really think that you need to hook up at least your video and boot to BIOS. Your description is not completely, well, descriptive.
April 24, 2012 2:42:57 PM

The CPU led is not supposed to stay red, I have hooked up my cards, 1 of them at least, it doesn't boot, it won't post or anything, the fans start, when I attach my mechanicals they spin, but the CPU led on my stays lit red and that's it. It goes no further.

Any ideas?
Related resources
April 24, 2012 2:48:24 PM

I put a mono speaker and there's no tones, it just won't post, I can't get the monitor out of standby even though all the LEDs on my FTC 560ti's go green.
a b Ĉ ASUS
a b V Motherboard
April 24, 2012 2:57:49 PM

If you got a FX series processor now in that board. Take your Phenom II and put it back in and go online to update the BIOS. FX Bulldozer requires a BIOS update to use it
April 24, 2012 3:05:41 PM

To be honest, I love my phenom 555 I know it's old but it's as stable as a house. No fx installed. The problem is with the phenom II be 555 and the sabre mobo. Thanks for the reply though.
April 24, 2012 3:57:22 PM

Ok, you didn't specify that the LED was red. Can you get another PII CPU to try? Maybe take the board to a local shop and ask them to try another CPU? After that, it is likely DOA. An FX chip should run on the 0901 BIOS without an update. I picked up a Phenom II 980 a couple weeks ago on Newegg ($150) as insurance and really wouldn't bother with FX chips right now. Lots of posts about that discussion here.
!