Sign in with
Sign up | Sign in
Your question

ASUS 6850 HDTV color problem

Last response: in Graphics & Displays
Share
March 4, 2011 2:50:25 PM

So this is a problem i have been having ever since i got my 6850. it occurs on 2 different rigs.

every once in a while (time varies) the color on my 1080p tv would INVERT. like blue will become red and stuff like that.

The funny thing is that once i make the slightest alteration to the display properties( like changing display resolution for 2 sec's ) it comes back to normal.

***This only happens on my fullHD tv. on a HD ready tv this does not happen. The TV's menu looks fine throughout

Temp is normal, drivers are updated and no OC.

again, this happens on 2 different rigs but the same card.

sys info

win7 64 bit pro
intel i5 2500
asus 6850



March 4, 2011 3:27:36 PM

Some questions so we can try to figure out what you can try:

Have you plugged anything else HD into the same port on your fullHDTV? Does it behave the same way?

Can you still return/exchange the card?
m
0
l
March 5, 2011 10:43:43 PM

the only other HD device i plugged in was a 720p TV and it works fine.

have not tried anything else on that port. will try plugging it in a different port to see if the port is the problem

cant return / exchange it.
m
0
l
Anonymous
November 29, 2011 11:05:15 PM

danw25 said:
So this is a problem i have been having ever since i got my 6850. it occurs on 2 different rigs.

every once in a while (time varies) the color on my 1080p tv would INVERT. like blue will become red and stuff like that.

The funny thing is that once i make the slightest alteration to the display properties( like changing display resolution for 2 sec's ) it comes back to normal.

***This only happens on my fullHD tv. on a HD ready tv this does not happen. The TV's menu looks fine throughout

Temp is normal, drivers are updated and no OC.

again, this happens on 2 different rigs but the same card.

sys info


Hey I recently googled this problem and saw this blog and saw that you were suffering from the same problem as me I just got a new PC and I'm using my HDTV as a monitor and the colour was going in mine too but I think I fixed it I went into my digital flat panels in the AMD contents and I went into pixel format and set it to RGB 4:4:4 full colour it was on the YcB one but since I switched it the colour doesn't go anymore and my PC uns perfect hope it helps you
win7 64 bit pro
intel i5 2500
asus 6850

m
0
l
!