Sign in with
Sign up | Sign in
Your question

ATI to Nvidia help

Last response: in Graphics & Displays
Share
March 5, 2011 3:39:41 AM

I recently sold my 5970 as it was overkill for the monitor I play on, I recently bought a single 580 and installed. I uninstalled all ati drivers using the uninstall and then using CCCleaner. However when I boot up games, it freezes and windows recovers from errors. Any other advice someone can offer?

Also when I boot up wow, the login screen and character screens look great and i get about 200-300 fps once I log into the game thats when the card locks up.

Can i do anything short of reinstalling windows and all drivers fresh?

More about : ati nvidia

a c 145 U Graphics card
March 5, 2011 3:43:22 AM

try using driver sweeper. uninstall the driver and use driver sweeper in safe mode to clear all left over by ATI and nvidia drivers. after rebooting you can run CCleaner if you want to before reinstalling the drivers for your GTX580
m
0
l
March 5, 2011 3:48:06 AM

ahh ok doing that now thanks!
m
0
l
Related resources
a c 106 U Graphics card
March 5, 2011 4:40:13 AM

So you sold your 5970 because it was giving you too much performance :o .

Anyway yeah, run driver sweeper. You can find it via google or in the downloads section of Guru 3D
m
0
l
March 5, 2011 11:20:18 AM

Yeah only play at 1920x1080 but may go bigger or multi display in the future I also play WoW alot which does not use both cards on the 5970.

In any event its not working, loading screens work but once the games launch to full screen the comp locks up and recoveres from a display driver error. Nvidia 266.66 display drivers ....windows recovered from error. It will even sometime reboot the computer. Any ideas or shall I reinstall fresh?
m
0
l
March 5, 2011 1:59:19 PM

I cannot figure it out, I will run fraps and the login screen in WoW works, runs at 250+ fps, then the char select screen works at the same fps. When I log in game freezes up dips to 1-5 dps and will recover from errors. I dont know whats wrong, could it be the physics part with nvidia drivers? Do i need to change a setting? I know its a driver issue and not the card because stuff in windowed mode work great its when I pop games into full screen. Any help or guidance would be appreciated.
m
0
l
a c 145 U Graphics card
March 5, 2011 3:33:20 PM

so did other games work just fine?
m
0
l
a c 609 U Graphics card
March 5, 2011 3:42:17 PM

Make sure the card and cables are all connected and seated properly. Then uninstall and reinstall your drivers. Last, go into the Nvidia Control Panel and make sure you don't have any weird setting enabled that may be interfering.

One good setting to change is "Multi-display/Mixed GPU Acceleration". Set it to "Single Display Performance Mode". For some reason, it defaults to Multiple display performance mode.
m
0
l
March 5, 2011 3:51:47 PM

Its all games when they click full.screen. yeah I was thinking it may be some weird setting will try.that when I get home. Could it be physics enabled too ? And its def the multi monitor setting since I did not change that yet.
m
0
l
a c 609 U Graphics card
March 5, 2011 5:39:48 PM

envymert said:
Its all games when they click full.screen. yeah I was thinking it may be some weird setting will try.that when I get home. Could it be physics enabled too ? And its def the multi monitor setting since I did not change that yet.

It wouldn't be a PhysX issue, since you are not playing a PhysX game. I have been assuming your power supply is sufficient because you were running a 5970, but if it's not driver related, that would be my next area to explore.
m
0
l
March 5, 2011 6:04:46 PM

Ahhh reading on it could be a number of things. It is a MSI 560 ti FROSR II and is factory Oced ....heard the OC is unstable with the new 266.66 drivers
m
0
l
March 6, 2011 1:21:28 AM

reinstalled windows frsh and running awesome!!
m
0
l
a c 609 U Graphics card
March 6, 2011 1:32:27 AM

That's great news. I was going to say you could try the 266.77 WHQL drivers available from guru3d.com.
m
0
l
!