Sign in with
Sign up | Sign in
Your question

I5 2500k high temps at stock speeds

Last response: in CPUs
Share
August 9, 2011 9:31:20 AM

I am getting 67 C temp reads when I go BIOS. My motherboard is MSI P67A-GD65. I saw that people are getting 30-40 C with stock speeds, then why am I getting 67C temp reads? Here is a CPU-Z and Core Temp screenshot-




Please help
a b à CPUs
a c 107 V Motherboard
August 9, 2011 9:33:16 AM

High temps (60-70ºC) in BIOS are normal with the stock cooler. The CPU cannot go into low-power idle mode until it boots into Windows.
m
0
l
August 9, 2011 9:46:49 AM

My temps go up to 75 C when I go in BIOS. Is this normal aswell?
m
0
l
Related resources
a b à CPUs
a c 107 V Motherboard
August 9, 2011 10:00:55 AM

The longer you stay in the BIOS, the higher it will go, up to a point. As long as it's not 98ºC (which would mean the heat sink isn't installed correctly), you're good.

Besides ... you don't plan on simply watching the BIOS for hours on end every day, do you?

Edit: Those screen shots were at idle? Or were you running Prime95 or something? I noticed the CPU was at 3.4GHz, which it shouldn't be unless it's under load.
m
0
l
August 9, 2011 10:12:38 AM

Yes, it was on idle. It always shows 3393 Ghz on CPU-Z. Is there something wrong with it? My clock ratio is 33 in BIOS. I have EIST enabled and C1E disabled
m
0
l
August 9, 2011 10:53:27 AM

Why is it showing 3.4 Ghz? My clock ratio is set at only 33. Its always showing 3.4, even on idle
m
0
l
a b à CPUs
August 9, 2011 11:38:57 AM

Do you have SpeedStep enabled? 2500K and 2600/2600K are supposed to drop to 1.6 GHz on idle... Also, see if there's a BIOS update for your board; Asus P67 boards were notorious for having high CPU temps before a BIOS update came out... maybe MSI suffers the same problem?

And check your fan profiles in your fan managing software (does MSI have one?), maybe the fan is set too low.
m
0
l
August 9, 2011 12:30:02 PM

I have EIST enabled, I don't know why its showing 3.4 Ghz. I have checked clock ratio at 33, C1E disabled, EIST enabled. Its still showing 3.4 Ghz on CPU-Z on idle
m
0
l
a b à CPUs
a b V Motherboard
August 9, 2011 3:30:00 PM

Check your power management setting in Control panel. If set to High performance that could be the reason as this may override Bios setting.

In Bios with stock HSF several have reported 60->65F, but normally dropps off once you are in Windows as Shadow indicated. In your case the idle temp is not dropping off because the cpu is not dropping to 1.6 GHz as Amk pointed out.

That said, 62 C is high for only 2-4% utilization. When you load the cpu your temps are going to jump to 75-85C. Use prime95 to load cpu, monitor your temps, probably will reach a high point (where you want to terminate the test) within 5->10 Minutes.

The first thing I would verify is that your HSF is installed correctly - did you watch one of the You tube videos. IE are all for white post sticking thru on the back side of the MB. are they all LOCKed.
m
0
l
a b à CPUs
a c 107 V Motherboard
August 9, 2011 6:20:15 PM

Query: Why is C1E disabled? These CPUs were specifically designed to have all of the power saving features enabled because most computers only need full CPU horsepower about 20% of the time. The instant your system needs full CPU horsepower it will ramp up to full speed, and the instant your system no longer needs full CPU horsepower, it will clock down to 1.6GHz. Allowing the CPU to idle at 1.6GHz really saves money on electricity, and it will have less "wear and tear" on the CPU.

Your CPU will never actually operate at 3.3GHz because of the Turbo Boost feature. With that enabled, whenever the CPU is loaded at all it will operate at 3.4GHz-3.7GHz depending on how many cores are loaded.

Oh, and (to answer your PM) Spread Spectrum is a technology that slightly varies the clock speed to prevent the computer from interfering with nearby radios and TVs (with static, snow, etc.). It's an old technology, and is unnecessary nowadays. Disable it.
m
0
l
August 9, 2011 8:30:56 PM

Excellent post MtnDew. I also have been guilty of "fooling around" with the BIOS settings to get a little more speed (Mostly on AMD CPUs). I must say since I got this Intel 2500k that all I did was use a pre-set in the BIOS to 4.4GHZ and did not change anything but did disable the Spread Spectrum. My CPU temps as measure by AIDA 64 ( I bought a license -worth it) are very cool with low power usage unless I need it for a COD BO "firefight".
I think these SandyBridge CPUs work very well with the power saving features in the P67/Z68 chipsets.
m
0
l
a b à CPUs
August 9, 2011 9:36:01 PM

What you really need to do is get coretemp and monitor your temps in Windows, both at idle and while under a heavy load. This is what really counts.
m
0
l
August 10, 2011 5:54:08 AM

This is after I enabled C1E-



Are these temps good for idle? And I am using Windows x64 so I don't have the power management options.

Anyway somehow its still bumping to only 3393 Mhz on load. I don't know why its not using turbo boost and not jumping to 3.7 ghz, I have turbo boost enabled in BIOS
m
0
l
August 10, 2011 6:53:16 AM

Does this have anything to do with turbo boost multiplier? I can't find that feature in my BIOS. Please help
m
0
l
a b à CPUs
a c 107 V Motherboard
August 10, 2011 7:19:44 PM

Okay, we really need to find out what your temps are when the CPU is fully loaded. Download and use Prime95 for an hour, and report back with the peak temps. With Prime95, your CPU should show up as 3.4GHz (or 3393MHz or whatever) in CPU-Z.

With the CPU at stock settings, it will only go up to 3.7GHz if one core is loaded. If two then 3.6GHz, if three then 3.5GHz, and if four then 3.4GHz.
m
0
l
a b à CPUs
a b V Motherboard
August 10, 2011 7:25:12 PM

^ +1
With your current Idle temps, you might not make an hour with Prime95. Within about 15 Minutes you should reach close to your max, BUT monitor the Temps CLOSELY during that first 15 Minutes, if less than 80C can let run longer but if you hit 85 C terminate the test.
m
0
l
August 13, 2011 12:12:09 PM

It reached 78 C within 3 minutes
m
0
l
!