Sign in with
Sign up | Sign in
Your question
Solved

CPU Fan Fail warning in my Dell...

Last response: in Components
Share
August 9, 2011 2:54:21 PM

Hey again.

I just installed an after market cooler (Coolermaster TX-3) in my Inspiron 580 and now whenever it boots up, I get the "cpu fan fail warning" screen. The aftermarket fan worx fine. It's a 4 pin just like the stock one. Maybe there's some proprietary wiring thing going on here? Is there any way to turn the warning off or get rid of the message? I saw no such options in the BIOS though...? Thanks! :D 
August 9, 2011 4:43:47 PM

They could have swapped the pwm/sense wires on the stock fan, do all the colors match in order on your coolermaster fan to the stock one? iirc, they use more standard parts now, but that isn't guaranteed. Although I think they use standard intel heatsinks and fans now. If not, well, a read of a bunch of forums on google indicates that they could have a custom ic on the original fan assembly that doesn't use the standard sense/pwn methodology.

You could also have accidentally disconnected another fan in the box also...although you should have gotten a chassis fan failure instead.
August 9, 2011 6:59:04 PM

The stock fan has blck/red/yellow/blue. The CM has blck/yellow/green/blue. The only colors that match (with pin placement)between the 2 are blck and blue (both outside pins). Not sure what a "standard" color for the pwm would be. The stock cooler that came with it is def an Intel cooler.

As far as the case fan goes (rear) I plugged that in and still got the warning.

It's gotta be something with the Dell (or should I foxconn(!)) MOBO. Because the MOBO's in my other 2 rigs I built with non stock Intel coolers didn't have this issue. At least it doesn't have that stupid 5 pin garbage my old P4 had...lol

Thanks for the help so far!
Related resources
August 10, 2011 1:16:52 PM

Any Dell experts out there?
August 13, 2011 3:22:26 AM

Any more takers? Please?
August 16, 2011 12:25:27 AM

*cough*
August 19, 2011 4:29:38 PM

*crickets*
August 19, 2011 6:39:55 PM

this is indeed a dell issue i had the same problem with my xps when i switched the cooler out. In my bios i was able to dosable cpu fan check and eliminated the bootup warning saying you have no cpu fan. Now do this at your own risk and make sure to monitor your temps with something like coretemp
August 19, 2011 7:04:01 PM

icehawk940 said:
this is indeed a dell issue i had the same problem with my xps when i switched the cooler out. In my bios i was able to dosable cpu fan check and eliminated the bootup warning saying you have no cpu fan. Now do this at your own risk and make sure to monitor your temps with something like coretemp


Maybe I missed it, but I didn't see any option to disable the cpu fan check? Do you remember where in the BIOS? The XPS , being Dell's higher performance line, might have more BIOS options than the Inspiron. Will look again.

Already have core temp, but thanks for the recommendation! Great app.

Thanks for the help. :bounce: 

Best solution

August 19, 2011 7:38:51 PM
Share

on the inspiron i believe its under power management also if you dont see a power management there might be an update for the bios. if you do get into power management what you can do is low power mode to off and suspend mode s1
August 19, 2011 8:37:46 PM

icehawk940 said:
on the inspiron i believe its under power management also if you dont see a power management there might be an update for the bios. if you do get into power management what you can do is low power mode to off and suspend mode s1


Will check into it. Thanks again! :D 
August 22, 2011 7:23:56 PM

Updated to A7 (latest) and still no option. The BIOS options are very minimal. Thanks anyway.

So, I'm just "stuck" hitting F1 on boot up. Thanks Dell.....
August 26, 2011 12:57:12 PM

Guess it's almost time to give up.

One last bump. Thanks to all those who helped so far! :bounce: 
September 2, 2011 2:00:41 PM

Best answer selected by VSTJuNkiE.
September 2, 2011 3:08:44 PM

Thanks to everyone who helped. I'm just stuck with this annoyance. Way to go Dell....*sigh*
!