Sign in with
Sign up | Sign in
Your question
Closed

HELP!!! Atheros AR5007 802.11b/g WiFi Adapter not connecting to router

Last response: in Wireless Networking
Share
November 19, 2010 9:19:51 PM

hi. ok so i have an hp dv9922us laptop. i recently tried upgrading to windows 7 but i had an issue with the drivers so i tried to reinstall vista. it took me a while but i finally have all the drivers updated and working. BUT for some reason i can connect only on the LAN and NOT the WAN. The router is working fine as i can use the internet on other computers as well as ps3. but for some reason everytime i try to connect wirelessly it tries to connect fails then says to restart router.

Atheros AR5007 802.11b/g WiFi Adapter = WAN Adapter
NVIDIA nForce Networking Controller = LAN Adapter

someone please help ive been working on this for hours and cant figure out wats wrong. Also, i would have just used the recovery disks that came with my laptop but i dont have them
Anonymous
November 19, 2010 9:24:00 PM

Is the adapter detecting the router ? Have you tried disabling wireless security.
Score
0
November 20, 2010 1:59:03 PM

yes the router is detected. and i have like no security. i try to connect then windows says cannot connect and shows the diagnose/connect to diff network options. also, if i try to connect to other networks it asks for security key , etc..
Score
0
Related resources
Anonymous
November 20, 2010 3:50:56 PM

Check TCP/IP Properties.

Start, Connect To, Connection, Properties, Scroll Down TCP/IP and highlight, click Properties and check that Obtain DNS and IP address automatically are enabled.
Score
0
November 27, 2010 7:48:47 PM

..they are
Score
0
March 8, 2011 7:53:05 PM

Goobshoeriot said:
..they are


Did you get a solution for this? I have a similar problem when trying to connect this adapter to the network i.e. works okay when security settings is open but fails to connect to internet when security settings is on.
Score
0
March 8, 2011 9:38:28 PM

surrey said:
Did you get a solution for this? I have a similar problem when trying to connect this adapter to the network i.e. works okay when security settings is open but fails to connect to internet when security settings is on.


nope sorry i still couldn't get it to work. i just said phuck it and ran a 30 ft ethernet cable to my room. so idn hopefully someone will put a good solution to this.

Also, just to make sure you got the same problem as me.. can you NOT connect ONLY from your "troubled" pc? cause i can connect on my ps3, other pc's, other laptop's etc... its only my computer(or network setup) that won't connect. makes no sense how can pc A connect pc B connect and not pc C.. i figure its gotta be something wrong with the setup right?! but as i said before i set all settings to automatic(tcp/ip, dns, etc)
Score
0
April 26, 2011 4:18:16 PM

The solution to this is so simple that I am ashamed to admit it took me 12 hours to figure it out. My machine is running Win Vista but I am sure that the operating system doesn't matter. This applies to the problem of your Atheros 5007 network device not allowing your computer to receive internet data, ie... you see your router but have no internet connection. Simply go into Network & Sharing center, then click on Manage Wireless Networks. Your router wireless network should be in the list. Highlight it, and then click on Adapter Properties at the top of the selection window. A smaller window opens for you Network Connection Properties, which lists Client for MS Window QoS Packet Scheduler, TCP/IP v6 and so on. At the top there should be a button that is named "Configure" under the Atheros device listing. Click it and you'll see a tab that is named "Advanced". You'll probably get a warning or two but continue on. There will be a list of of items, one of them being Network address. Once you click on it, you'll see two choices to the right, Value & Not Present. Not present is probably the one that has been selected. Click on Value & type in 192.168.1.1 and save it. Once you close out the setting windows, then try connecting. I hope this is helpful since it worked for me.



Quote:
hi. ok so i have an hp dv9922us laptop. i recently tried upgrading to windows 7 but i had an issue with the drivers so i tried to reinstall vista. it took me a while but i finally have all the drivers updated and working. BUT for some reason i can connect only on the LAN and NOT the WAN. The router is working fine as i can use the internet on other computers as well as ps3. but for some reason everytime i try to connect wirelessly it tries to connect fails then says to restart router.

Atheros AR5007 802.11b/g WiFi Adapter = WAN Adapter
NVIDIA nForce Networking Controller = LAN Adapter

someone please help ive been working on this for hours and cant figure out wats wrong. Also, i would have just used the recovery disks that came with my laptop but i dont have them

Score
0
April 26, 2011 4:58:17 PM

rpainter said:
The solution to this is so simple that I am ashamed to admit it took me 12 hours to figure it out. My machine is running Win Vista but I am sure that the operating system doesn't matter. This applies to the problem of your Atheros 5007 network device not allowing your computer to receive internet data, ie... you see your router but have no internet connection. Simply go into Network & Sharing center, then click on Manage Wireless Networks. Your router wireless network should be in the list. Highlight it, and then click on Adapter Properties at the top of the selection window. A smaller window opens for you Network Connection Properties, which lists Client for MS Window QoS Packet Scheduler, TCP/IP v6 and so on. At the top there should be a button that is named "Configure" under the Atheros device listing. Click it and you'll see a tab that is named "Advanced". You'll probably get a warning or two but continue on. There will be a list of of items, one of them being Network address. Once you click on it, you'll see two choices to the right, Value & Not Present. Not present is probably the one that has been selected. Click on Value & type in 192.168.1.1 and save it. Once you close out the setting windows, then try connecting. I hope this is helpful since it worked for me.


Close.. Very F'ing Close.. It was set to not present, i changed it to 192.168.1.1 but that didn't help. should it be set to the default gateway? cause maybe it's a problem that my default gateway and dhcp server are both 192.168.1.1. Anyways, thanks for the effort closest thing to a fix I've gotten yet.
Score
0
June 30, 2011 2:46:05 AM

That worked like a charm, have Vista on Compaq CQ50 w/ Atheros AR5007 802.11b/g, Setting the Network address brought up internet instantly. Thanks!!!!

rpainter said:
The solution to this is so simple that I am ashamed to admit it took me 12 hours to figure it out. My machine is running Win Vista but I am sure that the operating system doesn't matter. This applies to the problem of your Atheros 5007 network device not allowing your computer to receive internet data, ie... you see your router but have no internet connection. Simply go into Network & Sharing center, then click on Manage Wireless Networks. Your router wireless network should be in the list. Highlight it, and then click on Adapter Properties at the top of the selection window. A smaller window opens for you Network Connection Properties, which lists Client for MS Window QoS Packet Scheduler, TCP/IP v6 and so on. At the top there should be a button that is named "Configure" under the Atheros device listing. Click it and you'll see a tab that is named "Advanced". You'll probably get a warning or two but continue on. There will be a list of of items, one of them being Network address. Once you click on it, you'll see two choices to the right, Value & Not Present. Not present is probably the one that has been selected. Click on Value & type in 192.168.1.1 and save it. Once you close out the setting windows, then try connecting. I hope this is helpful since it worked for me.

Score
0
September 6, 2011 12:01:59 AM

Hey I think I have the answer to your prayers. plug in your ethernet cable to the computer that is messed up . go to this link: http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadInde...

download the updated driver
make sure you router passwords are correct: i.e (make sure if u are using WEP the router is on WEP and passwords match, or make sure you and router are on WPA-personal) etc..


hope this helps........God Bless...
Score
0
September 6, 2011 12:03:12 AM

This topic has been closed by Area51reopened
Score
0
!