Sign-in / Sign-up
Your question

Games only using 20% of CPU on battery?

Tags:
  • CPUs
  • Battery
Last response: in CPUs
August 10, 2011 8:58:49 PM

Well, I got a new lappy. It works great on battery, eats up whatever I throw at it. And gives it's resources to whatever needs it. When on battery, the multiplier still stays at a healthy 30, BUT the processor only allows the game to use around 20% of the resources! How can I fix this?!?! I have an intel i7 SB mobile chip (details in attached benchmarks).

GTAIV Benchmarks:

On AC:
Average FPS: 28.84
Duration: 43.51 sec
CPU Usage: 65%
System memory usage: 46%
Video memory usage: 88%

Graphics Settings
Video Mode: 1920 x 1080 (60 Hz)
Texture Quality: High
Shadow Quality: Very High
Reflection Resolution: Very High
Water Quality: Very High
Texture Filter Quality: Anisotropic x16
Night Shadows: Very High
View Distance: 100
Detail Distance: 100

Hardware
Microsoft Windows 7 Home Premium
Service Pack 1
Video Adapter: NVIDIA GeForce GTX 560M
Video Driver version: 280.26
Audio Adapter: Speakers (Realtek High Definition Audio)
Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz

On Battery:

Average FPS: 7.02
Duration: 44.02 sec
CPU Usage: 26%
System memory usage: 44%
Video memory usage: 84%

Graphics Settings
Video Mode: 1920 x 1080 (60 Hz)
Texture Quality: High
Shadow Quality: Very High
Reflection Resolution: Very High
Water Quality: Very High
Texture Filter Quality: Anisotropic x16
Night Shadows: Very High
View Distance: 100
Detail Distance: 100

Hardware
Microsoft Windows 7 Home Premium
Service Pack 1
Video Adapter: NVIDIA GeForce GTX 560M
Video Driver version: 280.26
Audio Adapter: Speakers (Realtek High Definition Audio)
Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz

More about : games cpu battery

a c 108 à CPUs
August 10, 2011 9:13:29 PM

try going to control panel--power options and change it to high performance--then go into the advanced settings and adjust them for on battery power
m
0
l
a c 323 à CPUs
August 10, 2011 9:15:42 PM

in your power options (in control panel) set your on battery mode to high performance.
m
0
l
Related resources
August 10, 2011 10:59:52 PM

That was the first thing I tried. Did I mention I built this lappy? (not a basic PC user). It seems to be another setting or an intel feature. The BIOS had no speedstep or C13 options.
m
0
l
a c 376 à CPUs
August 11, 2011 12:29:33 AM

*****READ THIS*****


There are two things you need to check:
1) Bottlenecks
Your CPU is only displaying about 20% because the graphics processing is the bottleneck.

My desktop PC uses, on average (varies by game) about 30% of my CPU's capabilities. If I were to switch to a more powerful card then my CPU would use even more of its capabilities in order to send the graphics card the information it requires quickly enough.

Everything is working fine on your laptop.

2) Battery vs plugged-in settings
In case I've misread your issue, try running the program 3DMark2001se (futuremark) which is free. Use the default setting as installed. Compare the value on battery with the value while plugged in.

If they are different this likely means you have changed setting for graphics and/or your CPU in your Power Control section. It's typical to have lowered settings in battery mode so you may want to change the CPU to max of 100% and full graphics processing (Google or type into "HELP" section on laptop to find the section I mention).

Let me know if either of my comments helped.
m
0
l
August 11, 2011 11:22:07 AM

Look at the benchmarks I posted (crude but they work) the graphics utilization is exactly the same in AC AND BATTERY, SO I'm not bottlenecking. I already went into power settings and set the minimum processor usage to 100%. Also, I used throttlestop to look at the difference between pluged and unplugged, multiplier is still running at a maximum of 30 on both battery and AC. The C0 state is still almost never used, the only difference is when the CPU idles, when on AC it stays at 70% C6 state, while on battery the processor stays at around 30% C3. Being a hardware specialist, I am still learning the ins and outs of these C states, but the difference is negligible in actual use. I'll run that benchmark and get back to you; I suspect it's not the processor, but how MUCH of the processor is allowed to be spent on a resource.

EDIT:
Scratch that, the C3 and C6 state is the same on both while idling.
m
0
l
August 11, 2011 11:54:21 AM

Sorry, that version of 3D mark won't recognize my hardware....
m
0
l
August 12, 2011 3:16:55 AM

TRIPLE POST!!!!!
BUMP
m
0
l
a c 376 à CPUs
August 13, 2011 12:31:16 AM

*You must have either your CPU or graphics capabilities turned down in your power settings to be getting lower frame rates on battery.

It's possible your laptop has other ways beside the "Power Options" in the Control Panel to adjust things.

Try running the "Windows Experience Index" on AC and on battery. If the CPU and/or graphics results are different you know which avenue to investigate.

It's possible your laptop manual may have a section on this.

**Do you have an "Optimus" laptop?

Summary:
Your problem is a software setting caused by one or more of the following:

1) CPU is set too low on battery
2) Main graphics card is set too low on battery
3) Two graphics cards exist and the low-end one is chosen on battery use
m
0
l
August 13, 2011 4:52:48 AM

Firstly, I use the 560M GTX, Nvidia never even programed that optimus crap for this baby! I put the PC together myself, it has no manual. In the Nvidia control panel, I set power conservation to off. May be a BIOS issue, but I'm leaning towards an intel throttle... Also, windows doesn't allow WEI testing on battery power, I posted the AC scores to brag a little.

WEI on AC:
Processor: 7.5
RAM: 7.8
Graphics: 7.2
Gaming Graphics: 7.2
HDD: 5.9
m
0
l
a c 376 à CPUs
August 13, 2011 5:41:59 AM

I have no further advice.
m
0
l
August 13, 2011 10:57:32 PM

okay, also, throttlestop benchmarks show no difference in CPU performance...
m
0
l
a b à CPUs
August 14, 2011 4:02:26 AM

Throttling is usually triggered when you are using both the CPU and GPU at the same time. The ThrottleStop benchmark is only stressing the CPU so it's not surprising that you don't see any problems.

Check the Log File option in ThrottleStop and then go play for a while. It will provide you with some evidence of whether your CPU is throttling or not. Turn on GPU temperature monitoring in ThrottleStop. This can provide clues if the GPU is throttling. The CPU multiplier might be high but CPUs can be throttled internally so the multiplier by itself may not be a good indication of throttling. The two clock modulation columns in ThrottleStop should always show 100.0 in the log file.

Upload ThrottleStopLog.txt to www.mediafire.com when you are finished gaming and then post a link here. GTA IV is causing problems for lots of different laptops. Here's an example of an Asus G73SW throttling when plugged in.

http://www.youtube.com/watch?v=0JdRUHHn0UM

The C0% data in the ThrottleStop log file is a very accurate indication of how much of your CPU is actually being used.
m
0
l
August 14, 2011 4:48:05 AM

Check your event log to see if your comp automatically throttled down your cpu, and make sure it's not a bottleneck. Do you get the same results with AC and battery? If so, it is most likely a bottleneck, if not, then it has something to do with your power/cpu settings. You can access them through the control panel. How much memory is on on the graphics adapter and is it dedicated?
m
0
l
August 14, 2011 4:49:16 PM

unclewebb said:
Throttling is usually triggered when you are using both the CPU and GPU at the same time. The ThrottleStop benchmark is only stressing the CPU so it's not surprising that you don't see any problems.

Check the Log File option in ThrottleStop and then go play for a while. It will provide you with some evidence of whether your CPU is throttling or not. Turn on GPU temperature monitoring in ThrottleStop. This can provide clues if the GPU is throttling. The CPU multiplier might be high but CPUs can be throttled internally so the multiplier by itself may not be a good indication of throttling. The two clock modulation columns in ThrottleStop should always show 100.0 in the log file.

Upload ThrottleStopLog.txt to www.mediafire.com when you are finished gaming and then post a link here. GTA IV is causing problems for lots of different laptops. Here's an example of an Asus G73SW throttling when plugged in.

http://www.youtube.com/watch?v=0JdRUHHn0UM

The C0% data in the ThrottleStop log file is a very accurate indication of how much of your CPU is actually being used.


On another note, the throttling is probably not temp based, because only 20% of the CPU is utilized in many games, during cold boots and high performance usage. Also, I HATE mediafire, so Imma upload to mega upload instead.

EDIT:
both columns both show 100% in both uses
m
0
l
August 14, 2011 5:06:18 PM

Double Post:
Ok, I've run the logs.
http://www.megaupload.com/?d=8PEADG9H
Order:
Short period of Idle on AC
Gaming on AC with FPS locked to 30
Gaming on AC with FPS unlocked running at 80
Gaming again on AC with FPS locked to 30
Short period of Idling on battery
Gaming at 23 FPS on battery
Short period of Idling
m
0
l
a b à CPUs
August 14, 2011 7:16:45 PM

The CPU does not show any signs of throttling in the log file you posted.

When you are running on AC, the GPU temperature is almost 20C higher compared to when you are running on battery power. If you were playing the same game, that's a good sign that the GPU was being throttled. The CPU is not being throttled. When the GPU gets throttled, your multi-threaded CPU simply has a lot less to do and that is why the CPU C0% drops when this happens.

Try running a GPU-Z log. You might see your GPU MHz or GPU memory MHz drop down when you switch to battery power.

I've heard that some modern Nvidia GPUs can be throttled internally so their might not be any difference in the GPU MHz numbers when you switch to battery power. The last time I saw this, there was other information that GPU-Z logs that showed that the GPU Load was reduced and I think the Memory Controller Load was also noticeably reduced.

If the MHz isn't dropping down then I don't know of a way to prevent this type of throttling.

I prefer MediaFire to MegaUpload because with MediaFire, I don't have to wait 60 seconds for a download to start.
m
0
l
August 14, 2011 8:47:50 PM

Mediafire is ad riddled and creates dead downloads.

Thanks for the help! I guess that I'll have to overclock the GPU to it's standard performance while on battery.
m
0
l
a b à CPUs
August 14, 2011 10:59:07 PM

I am using Google Chrome with AdBlock. If you use that, MediaFire works well.

https://chrome.google.com/webstore/detail/gighmmpiobklf...

Without AdBlock, a person could have an epileptic seizure from the flashing pop up jungle.

Many laptops throttle the CPU or GPU or both when running on battery power. This is designed to protect the battery. Drawing too much power out of a laptop battery on a regular basis can shorten its expected life. Best to save GTA IV for when you are plugged in.
m
0
l
August 15, 2011 1:51:37 AM

meh! I can always buy another battery, but never the time I could have otherwise wasted stealing digital cars!
m
0
l
a c 376 à CPUs
August 15, 2011 10:31:53 PM

For all the good it will do, I'll throw in some advice again:

1) I don't believe there are any BIOS settings related to throttling graphics automatically.

2) Still, I assume you have an up-to-date BIOS (I know you built it but I assume there is a BIOS site for that board.)

3) I still can't think what else it could be aside from a Windows power setting.

4) Do you know enough about Linux to install Ubuntu Live using Ubuntu, then find a benchmark utility which uses the CPU and graphics. you could then benchmark with battery and AC again but in Linux this time. You'd need an up-to-date driver. There should be an option to install one in the upper-right of Ubuntu. Apply any updates through the software manager.

It's not ideal, but if it worked here it proves a software issue in Windows.

Sorry if it's not helpful, it's only slightly better (maybe) than telling you not to use it because it could shorten your battery life (sigh. why would someone write that..).

Anyway, I've built lots of desktops but never a laptop. I would have thought the process to be similar.

Summary:
1) Windows power setting?
2) NVidia Control Panel setting?
3) benchmark in Linux (Ubuntu, installed with WUBI. removed through Control Panel).
4) BIOS up to date? Any settings?
5) Possible battery issue of insufficient power? (not likely.)
6) Main chipset driver for motherboard installed?


Good luck.
m
0
l
a c 376 à CPUs
August 15, 2011 10:37:37 PM

To be clear, I believe that your NVidia graphics card is being throttled.
m
0
l
August 16, 2011 12:02:41 AM

It most, likely is. The panel doesn't cover throttling and it is NOT a power setting. I guess It'll have to be a manual overclock to a standard speed.
m
0
l
a c 323 à CPUs
August 16, 2011 2:33:44 AM

I might have found a gem; try this:

in the nvidia control panel, in the 3D settings > manage 3D settings; Set power Management Mode to 'Prefer Maximum Performance'
m
0
l
August 16, 2011 10:21:02 AM

popatim said:
I might have found a gem; try this:

in the nvidia control panel, in the 3D settings > manage 3D settings; Set power Management Mode to 'Prefer Maximum Performance'


I had a similar problem on my old gaming laptop (2009) and this worked back then. I will also suggest trying this.
m
0
l
August 16, 2011 11:53:30 AM

Already did that.... Didn't seem to help.
m
0
l
a c 376 à CPUs
August 16, 2011 3:14:40 PM

Are you absolutely certain that there is no BIOS setting for throttling the graphics on battery?
m
0
l
a c 376 à CPUs
August 16, 2011 3:17:59 PM

This won't directly help, but I found this in an article about Dell laptops:

"Some of these XPS systems were found to have throttling issues when demanding applications like games were run on them. Dell was able to provide a fix for the issue with the help of community input. The fix involved bios updates and a more powerful AC adapter.[14][15][16] Other laptops were also found to suffer from the same throttling issue."
m
0
l