Sign in with
Sign up | Sign in
Your question

P8Z7-M Pro Detects graphics card as PCIE 0x

Last response: in Motherboards
Share
April 29, 2012 1:13:27 PM

I recently decided to build this new computer:

Asus P8Z77-m Pro
Intel i5 3570k
Corsair Vengeance 8 GB
Corsair Force GT 120 GB
Western Digital Caviar Black 1TB
Zotac GTX 560 Ti 448 Core
Corsair H80
Asus DRW-24B1ST DVD Writer
NZXT Sentry 2
Corsair TX750
Zalman Z9 Plus Tower
Asus PCE-N15 300 Mbps wifi adapter

Everything seems to be working fine aside from my graphics card. In the bios, it detects the card as a PCIe card at 0x, not 16x like it should be. If I try to install the Nvidia drivers under Windows, it says graphics card is not detected. Using the built in graphics via Ivy Bridge works perfectly fine, however I get no output via the 560 from HDMI or DVI.

I've tried reseating the card, and made sure it was seated properly in the blue PCIe x16 slot. All the required power cables are plugged in. I also tried the card in the second PCIe x16 slot, and got the same error, where it showed up as a x0 device. I've updated the bios firmware on my motherboard to the latest version, along with the drivers/firmware of every other device connected to the computer. I also tried disconnecting everything but the graphics card, CPU, RAM and boot drive, still no output on the graphics card.

I'm beginning to think it's either my graphics card or motherboard that's faulty. Everything is less than a week old, but the last thing I want to do is take apart my entire rig if it is in fact a problem with the motherboard. Any help is greatly appreciated.

EDIT: Going to see if I can go over to a friends today and try my card out in his computer.
May 22, 2012 9:46:19 PM

I have the same problem. The motherboard is the same as yours, but the video card is gtx 460. The video card works only on the 3rd slot(4x). On the 1st and 2nd slot I get "no signal" and in bios I have 0x speed.
I tested with two other cards: nvidia 9600 and some AMD/ATI board, I do not remember what was the gpu, but it was stronger then my 460.
I also tested my gtx460 in another pc and I get signal when is seated on 16x slot. The problem is that it is detected @4x.
Soon I will crash it with a hammer.
Please help !
m
0
l
a b U Graphics card
a b V Motherboard
May 23, 2012 4:10:25 AM

Let me know how it goes taking it over to the friend's house.
m
0
l
Related resources
May 26, 2012 10:08:40 PM

I cleaned the vga with isopropylic alchool, but is the same. It only works in the last pcie slot which is @ 4x. On other motherboards, works in first 16x slot , but is detected @4x.
Please help ! Can somebody help please?
Thank you!
m
0
l
a b U Graphics card
a b V Motherboard
May 27, 2012 10:32:59 PM

Sounds like the video card is faulty.

It seems to have had the same sort of problems on two different motherboards, so it sounds like the motherboards have nothing to do with it.

I would be examining my warranty information if it were me.
m
0
l
May 28, 2012 4:28:59 AM

Thank you for your reply! Well, my warranty is gone...It looks that I will use it in 4x slot. I activated VirtuMVP and it has amazing performance. The only problem is that is at the bottom of the case and it is not very well cooled. I will try to wash it again with alchool.
m
0
l
a b U Graphics card
a b V Motherboard
May 28, 2012 6:33:57 PM

That is too bad, I hope it works out then.

Most video cards aren't bottlenecked at x8, but x4 may impact performance. At least it doesn't seem to be doing too bad in your testing.
m
0
l
!