Sign in with
Sign up | Sign in
Your question

HP DV2988SE does not see all my RAM

Last response: in Memory
Share
April 30, 2012 5:19:45 AM

I replaced the screen of my laptop and re installed the Operating System using factory restore disks. I installed the factory 4GB of DDR2 ram in my laptop but under control panel< system, it only shows 2GB of RAM. The operating system that was loaded from the factory was Windows Vista Home Premium 64 bit SP1 and that is what I currently have. I tried removing and reinserting the RAM and it still claims I installed 2GB of RAM but I am positive I installed 4GB. I tried going into the BIOS but the only options that were shown are Hard Disk Test and Memory Test. I tried the memory test and the problem was not resolved. I have a feeling I need to flash the BIOS with the newer one HP provided but I want that to be a last resort.
Thank You.

specs:
320GB Hard drive
4GB installed RAM but the computer is saying 2GB
WIndows Vista Home Premium 64bit SP1
Intel Core Duo CPU T5750 2.0GHZ

More about : dv2988se ram

a b } Memory
a b α HP
April 30, 2012 7:06:58 AM

Try removing the top ram module and rebooting (if you can boot with one). If you can boot with one module and it shows 2GB, it may be that one of the ram modules is bad. Try it with the other see what happens then...
m
0
l
May 1, 2012 12:25:31 AM

I think I may have a bad RAM because once I removed one RAM and started up the computer, there were 3 beeps and the computer did not start. I installed both the RAM modules and removed the CMOS battery and re inserted it and now my computer shows 4GB of RAM. I'm confused, like do I have bad RAM or did I need to reset my motherboard because the laptop has been in storage for about a year.
m
0
l
a b } Memory
a b α HP
May 1, 2012 3:31:17 AM

Guess it just needed a jolt to get it fully awake after one years sleep - sounds like plug 'n play wasn't detecting new hardware - it could've been disabled in the BIOS. You can run memtest if you're concerned the ram may be bad but I'd just be happy and keep a watch for stability issues (random freezing and the like)
m
0
l
!