Sign in with
Sign up | Sign in
Your question

Did I kill it?

Last response: in Motherboards
Share
May 1, 2012 11:21:36 PM

Just replaced my old failing PSU and when I was switching it out for the new one I had to take the front panel (led/power switch) cables off. I put it all together and when I went to boot nothing happened. Upon closer inspection I noticed that I had the power switch connector off by one pin which mean one of the 2 pins was where an LED connector should have been. So I fixed it but it still will not book. I tested the power supply on another motherboard and it booted fine. I also tested the old power supply on the mobo and it still wouldnt boot.

I cleared the cmos and I tried the bare min (take every cable off but the 24 pin and jump the power manually with a screw driver) and it still didnt boot.

So this is a last ditch effort. Im 90% sure i fucked up the board but feel free to correct me and tell me what I may have missed.

Board is a ASRock Extreme3

More about : kill

May 2, 2012 12:56:55 AM

I think you may have. Was your screw driver insulated? Do you think you may have caused a short by electrostatic discharge (either through the screwdriver or your hands)? Your probably going think this is going to so silly, but I have to ask, you did turn the standby switch on the back of the power supply?
m
0
l
!