Sign-in / Sign-up
Your question

USB 3.0 external hard drives not working with ANY ports

Tags:
  • Motherboards
  • USB3
  • External Hard Drive
Last response: in Motherboards
May 3, 2012 4:41:00 AM

So, I have a P9X79 motherboard, and I have 4 internal hard drives connected via SATA, one USB 2.0 external hard drive, a USB 3.0 external hard drive, and another USB 3.0 enclosure holding 2 hard drives. This afternoon, all drives were working as expected. Then I installed the Asus Ai Suite and activated "USB 3.0 Boost" on the 2 USB 3.0 external hard drives that I had connected at the time. When I rebooted I couldn't get them to appear in Windows. I tried clearing the CMOS, uninstalling and reinstalling the driver, and getting rid of anything to do with Asus Ai Suite and USB 3.0 Boost, but nothing changed. Here are the devices I tested and what they worked with:

USB 3.0 External HDDs: don't work with 3.0 OR 2.0 ports
USB 3.0 USB Flash drives: work only with 2.0 ports (these were not attached at the time of installing USB 3.0 Boost)
USB 2.0 devices: work fine whether attached to 2.0 or 3.0 ports...this is true of flash drives, input devices, and the external hard drive

Then I did a complete clean install of Windows. Now the USB 3.0 flash drives will work in the 3.0 ports, but the USB 3.0 external hard drives still don't work in any ports. Additionally, I connected the USB 3.0 external drives to my laptop (which has only 2.0) and they worked just fine. I called Asus support and all they keep telling me is that I should return the board, but I don't see how the motherboard could be having issues if the issue is only relegated to the external hard drives. This problem is extremely vexing, please help!

More about : usb external hard drives working ports

May 3, 2012 4:43:49 AM

Immediately after posting this I unplugged the USB 3.0 enclosure with the single drive, then powered it off and back on and plugged it back in to a 3.0 port, and it shows up in Windows...problem may be relegated only to the enclosure with 2 hard drives.
m
0
l