Issue with dual channel and Asus F1A75-M PRO

Hello all, I recently bough an Asus F1A75-M Pro with a A8-3870k stuck on it and Patriot G2 4GB 2x2 @ 1866.

The problem is that cpuz doesn't show me if Dual Channel is activated



So, how could I check if it's active? Notice that I added both memory stick on different ranks, one is on rank 1 and the other on rank 3.

Thanks
14 answers Last reply
More about issue dual channel asus f1a75
  1. Hello,

    An easy test to see if your computer is using dual channel mode is check your WEI index score for your RAM. If it's above 7 dual channel mode should be working.

    You mentioned the ram is in banks 1 and 3 - which is correct for dual channel operation.

    Sometimes CPUz is somewhat outdated depending on which platform it's scanning.
  2. No, that's the problem, the score is on 5,9.. thanks.
  3. Feche said:
    No, that's the problem, the score is on 5,9.. thanks.


    Ahh ok. Have you tried the other RIMM slots on your motherboard? Swap em around and see what happens. Of course do it while your computer is off :D

    Edit: Which version of windows are you using, and what bit? Example - windows 7 32bit.
  4. Okay, I will try rank 2 and 4.

    Right now I'm using Windows 7 64-bit.
  5. Okay changed the ranks and I still get 5,9 on WEI, what could it be? Help please!

    Thanks
  6. Hmm ok. I wonder if it's because you "only" have 4GB of ram.

    However going through your manual - it states you should put the ram in the blue slots for max OC ability (if you plan to do so).

    One last thing - have you tried setting the CAS latency of your RAM? Also - what exact model number is your RAM? You should set them to the manufactuerer's specifications in your BIOS.

    One more thing you mentioned your ram is 1866 - however I can't find that exact model...the closest one I found was Patriot G2 1600Mhz 2x2GB. I know the A8's are highly sensitive to RAM since they use it for the igpu as well.
  7. Yes, my exact RAM is Patriot Gamer 2 Series 4GB (2 x 2GB) DDR3 1600 PGD34G1600ELK 9-9-9-24.

    I have them at 1866mhz 10-10-9-24 @ 1.8v.

    I switched the ranks again, and there is no change on the WEI score and/or performance.

    Thanks again
  8. Someone please? :(
  9. Have you tried updating your BIOS to the latest version?
  10. It might be helpful :)

    www.ehow.com/m/how_5085033_test-dual-channel-memory.html
  11. Yes, I have the latest BIOS.

    I do not need to test the stability of the dual channel , I need to know if it is activated!

    Thanks all
  12. www.tomshardware.com/forum/293098-30-cpuz-showing-dual-channel
  13. www.gtopala.com/
  14. I found out that is activated using Aida 64:



    And I have 5,9 becouse I have less than 4gb on a 64 bit OS. (3,5, 512 is using the IGP)

    Thanks to all. :)
Ask a new question

Read More

Asus Dual Channel Motherboards