8800GT green artifacts

Hi all.

I've got a problem with my 8800GT OC2 - there are green artifacts all over the screen right from when I turn the computer on. These are initially blocks all over the boot screen, but then become a series of green lines over the desktop, which is not at the ideal resolution because Windows says "the device isn't working properly" etc. in device manager. Also Rivatuner now fails to detect the card.

I would RMA, but it turns out I'm a little late to the party, and BFGTech went bust a year ago.

I have tried googling and got a few suggestions, mostly about temps, which have always been high on this card. I flashed the bios shortly after I bought it and upped the fan speeds, it has always worked fine no problems, but does get to the high '70s still when playing games. Idles probably around the fifties somewhere.

Is there anything I can do to fix this? I'm pretty doubtful, because these artifacts appear right from a cold boot, but any ideas are very much appreciated.

Thanks all, Michael.
2 answers Last reply
More about 8800gt green artifacts
  1. Apart from baking it (I am serious) then it is replacement. Baking is worth a try if you want to save money. http://hardforum.com/showthread.php?s=ce00cb5b84246fcb786c5f3ca7630bc6&p=1034145333#post1034145333
    There are guides if you google.
  2. Thanks for the suggestion. I gave it a go, and nothing fell off or broke so far (bit of a funny smell though - hopefully the family won't die next time something gets cooked in the oven).

    Slight problem is that I now need some thermal paste for the GPU, and also a thermal pad for the memory - when I hoovered dust off the card one of these flew into the hoover :/

    Anyone know what paste/pad to use? Cheers.
Ask a new question

Read More

Graphics Cards Green Graphics