Sign in with
Sign up | Sign in
Your question

Faulty RAM or is it the motherboard?

Last response: in Memory
Share
May 4, 2012 2:44:10 AM

Hi everyone,

I have an Asus P5Q SE Plus motherboard with 4 x 2GB sticks (two matched pairs) of Kingston Hyperx DDR2 800MHz/PC2-6400 HyperX Memory CL5 1.85V installed. Until recently I was running these with an Intel E6300 dual core CPU and experienced no problems. However, I recently upgraded the CPU to an Intel quad core Q9400, and it was after this that I started to experience regular BSOD crashes in Win7 (64-Bit). The voltage in BIOS is set to 1.9v (1.85v is not available) and the CAS is manually set to 5-5-5-15. The slot configuration for this board in dual mode is A1 + B1 =Channel 1, and A2 + B2 = Channel 2. I tested the RAM sticks individually in each slot with Memtest v4.2.

These are the results when each stick was tested one at a time in each RAM slot:

Every stick passed in slot A1;
Every stick passed in slot A2
Every stick failed in slot B1;
3 sticks failed and one passed (5 test passes) in slot B2.

All the failures occurred within either one or two test passes.

Does this mean that the RAM looks good but slots B1 and B2 are faulty? Could the new quad CPU be faulty and affect the results?
I had already flashed the BIOS to the latest version long ago after about a week of operating the computer, but would there be any point in reflashing the latest version?

Thanks in advance.

More about : faulty ram motherboard

a b } Memory
a b V Motherboard
May 4, 2012 2:56:39 AM

Sounds like the socket is bad. Put the old CPU in to confirm (if you can), but I suspect that B2 socket. (why would B1 be questionable?)

The V should be at 1.85, not 1.9, but with everything you have said and tested this comment is kind of moot.

EDIT: reply or edit your OP with the exact part numbers of your RAM so we can tell if the timings are right. CPUz can help with this, but since you're moving modules around, I don't think you'll need this.
May 4, 2012 3:48:29 AM

Thanks for the fast reply psaus.

I don't understand why you said "(why would B1 be questionable?)".

1.85V is not available in my BIOS. When it's set to default it goes to 1.8V, so 1.9V, being the next available one up is the safer of the two. However, I notice that CPU-Z still shows 1.80V. Is this normal? I'm a bit new at this, I've previously just been content to fit hardware in and leave it at default, no messing about with the settings.

The part no. is KHX6400D2K2/4G.
Related resources
a b } Memory
a b V Motherboard
May 5, 2012 9:17:46 AM

Sorry for the late reply, and confusing on at that (apparently I was starting to get sick, as I woke up yesterday with a ridiculous fever).
Therefore strike my "why would B1 be questionable". I misread your OP.

Next step, just reset CMOS and run with default settings. The RAM should be more than able to run the timings you have them set at, but just in case do a reset and run at default settings.

Re: the V discrepancy. This can be from 1 of 2 reasons; A) BIOS mfgs let you set setting @ X but in reality they mask it and the real setting is X - .0Y. Or B), the component reading the V is off by just a touch in it's reporting.
I wouldn't worry about it too much. If you're desperate or really curios, bump it one more above the 1.9 setting (either 1.95 or 2v, depending on what you have available) and see what CPUz says. But I think this is inconsequential...

Lastly, do you still have the last CPU available? Just to put things back the way they were to test in that configuration?
a b } Memory
a b V Motherboard
May 6, 2012 8:51:33 AM

Which BIOS version you have in rig ?
May 9, 2012 2:08:33 AM

Thanks for the advice psaus, but whilst waiting for your response I made different searches on Google for the solution and, thanks to something I found, it looks like I've solved the issue. sorry I didn't get back earlier but I've had trouble being able to post on here for the past few days, being told that the forum is not available.

Anyway, I disabled 'CPU Spread Spectrum' and 'PCIE Spread Spectrum', both of which were originally enabled at 'Default'. I tried running two passes of Memtest and it showed no errors. So before going to bed I took the liberty of touching the RAM voltage up to 2.0V and knocked the clock speed up a little from default 333MHZ (if I remember correctly) to 350MHZ. I left Memtest running all night with all the sticks in, and no errors appeared after seven passes. When I originally tried this, errors appeared within the first pass, but now it's dead clear. My RAM is now at 840 MHZ instead of 799 MHZ.

I don't know whether it was one or the other, or both of the disables that solved the problem, but I'll check that when I get the time.

I had always assumed that default settings were the very safe and reliable settings, but clearly not.

Do you (or anyone else) have any opinions to add about what I've done?
May 9, 2012 2:15:21 AM

THE UNKNOWN said:
Which BIOS version you have in rig ?


I have the latest installed. However, I've replied to psaus with what I found to be the solution. Thanks anyway.
a b } Memory
a b V Motherboard
May 9, 2012 9:29:33 AM

Sounds like the problem is fixed, and therefore I'd say that's the biggest thing.

First, I'd like to comment on your RAM settings. Essentially, you went overclocked with those settings. If you intended that and/or are happy with that, enough said. :)  But more importantly, if you achieved that speed with 5-5-5-15 timings, then awesome. But if you sacrificed to higher timings for that speed, I would suggest 5-5-5-15 are likely more beneficial than an extra 50MHz at worse timings.

Back to the original problem & Spread Spectrum; I'm interested to hear if any other problems might have come up (fingers crossed not). I ask that because Spread Spectrum is used for security and performance reasons. Essentially it makes extra noise. If your system can't handle this extra noise, I could see problems arising when the system is properly stressed (e.g., newest game, heavy processor usage, etc). Maybe not though and you'll be ok.

If you want to investigate this, my 2 suspicions are Case or Power Source. But at the end of the day, I wouldn't go chasing this until I ran into more problems. These tests are a pain in the ***, and if your system is running stable, then you've fixed it. Just keep this in the back of your mind if something rears its head down the road (e.g., crashes/errors during heavy computing).

Case:
- Either the motherboard is not installed properly - plastic stand offs were used instead of metal stand-offs.
- Or the case is not a good case and reflecting the extra noise and interfering. (an analogy would be that scenario when you have really bad cell reception and you hear your own voice a half a second later :pt1cable:  ). If you have a decent manufacturer for your case, you're probably ok here. Only those really cheap ones do this in this day and age.

Power
- PSU can be a factor here. I'm less likely to suspect it if you've been running this system for a while (which I believe you have been). If the PSU is a problem, it's because it's from a crap company like SparkOmatic, or it's faulty. Again, not suspecting this too much, because as I'm understanding, this isn't a new build. Just an upgrade.
- Power Source (wall socket) - this may not be grounded at all, grounded well, or may have background noise. There are testing devices you can buy for this for cheap to test the ground (Amazon, Harbor Freight, etc). Alternatively, you can move the computer to a "known" good socket for temporary testing.
Background noise means there's something else on this circuit that sends a lot of electrical noise down the line. Refrigerators are notorious for this, but in the US most kitchens are on their own breaker(s). But not always. The culprits to look for are things with heavy power draw, and most often things with a motor in them. The test for this is simple, unplug them while you run tests.

Again, I'd probably not go down this road if the system is stable. :) 
Good luck, and hopefully this is the end of it.
!