Sign in with
Sign up | Sign in
Your question
Closed

Z77 Sabertooth and Ram Issue

Last response: in Memory
Share
May 5, 2012 3:12:22 AM

Hello all,

I have just put together my first build a couple of days ago. Right from the very beginning my memory kit (4x2GB G-Skill Ripjaws) would not work with all four sticks. After i removed one of the sticks i was able to post and begin installing windows. Then later that night during a restart of the system, the motherboard's dram led was lit again just as in the beginning. This occurred again until i was down to one stick of ram and then the system worked stably (was able to play games and run prime95 for over two hours with no problems). And now my computer turns on and after 4 sec it shuts off and repeats this cycle. I do know now that my ram kit is NOT on the motherboards QVL (at the time of purchase of the ram I did not have the motherboard QVL). If theres way to get this current set to work it would be greatly appreciated.

Here are my components:
Intel i5-3570k
Corsair H100
ASUS Sabertooth Z77
EVGA GTX 570
Patriot 60GB SSD
WD Caviar Black 1.5TB HDD
Corsair AX750
a b } Memory
May 5, 2012 4:21:58 AM

Check by putting single sticks everytime if problem occurs check by other working ram not by gskill that you bought if no problem it might possible your gskill faulty.
Score
0
a c 85 } Memory
May 5, 2012 4:40:44 AM

i had a 16g set i got off on new egg last month before the 77 mb came out. the one i bought said for z68 chipset so i thought i was fine. got the red dimm led right at power up. becasue it was after 30 days i had to rma back to gskill wont get a replacement till sometime next week. if your under the 30 days send them back and get ram on the list. all i can tell you i think asus rushed this board out to market...looks great but has a ram weakness that other vendors boards dont have.
Score
0
Related resources
May 5, 2012 4:53:25 AM

try dropping the RAM frequency to 1333, I have 2 2x2Gb G.skill1600C7 and only 4Gb would be detected at post. when I dropped the freq. to 1574 it shows 6Gb and @ 1554, all 8gb loosening timing to Cl9 doesn't do anything.
Score
0
May 5, 2012 4:06:01 PM

So far none of your answers have worked but i did find another symptom. I can get 2 sticks to work in single channel mode (two sticks right next to each other). Then put the mobo in OCTUNE and it came back with a frequency of 1372 MHz.
Score
0
a c 102 } Memory
May 7, 2012 4:24:33 PM

Sounds like it may be a problem with the motherboard. As "THE UNKNOWN" stated, it will be a good test with memory other than G.Skill, or different G.Skill memory to see if it will have this same problem. If so, then you know it is probably a problem with motherboard. Get that replaced and the memory should work without a glitch. If the memory is better than DDR3-1600 CL11, enable XMP, and you're ready to go.

Thank you
GSKILL SUPPORT

Score
0
May 17, 2012 12:53:57 PM

I'm having similar problems with the Z77. It works with GSkill 2133MHz 4x2GB, but not with Patriot 2GHz 4x4GB or Team Extreme 2600Mhz 4x4GB. It seems to have a problem with the larger capacity 4Gb sticks. I've also tried 2 different 3770K chips and 3 different BIOS revisions and with both XMP and manual configuration of the memory.

I've raised a ticket ASUS and I'm waiting to hear back from them.


Score
0
May 31, 2012 12:34:58 AM

I'm having similar problems. I also contacted ASUS about 9 days ago, so far no answer. Good luck.
Score
0
a c 102 } Memory
May 31, 2012 6:34:59 PM

:hello: 

try me, I have good knowledge about ASUS and G.Skill so I can do my best to help. :bounce: 

Thank you
GSKILL SUPPORT
Score
0
June 16, 2012 9:18:32 PM

Just an Update, I reinstalled windows and it fixed my issues. Might have had a bad OS install. Might help you also.
Score
0
July 5, 2012 2:26:50 PM

I havent installed my OS yet, but When I boot up I see that my ram http://www.frys.com/product/6751425?site=sr:SEARCH:MAIN... PC1600 DDR3 240-pin 16gb is showing up correctly and seems to be running fine, HOWEVER! at boot and when I enter BIOS the ram is reading at 1372MHZ? Whats going on, and ideas? I have NOT installed a OS yet. My mobo is Asus Sabertooth Z77
Score
0
a c 347 } Memory
July 5, 2012 2:45:56 PM

Interesting... What exact Kits? Most problems short of a bad stick or sticks is due to mixing sets including (2) identical sets but expecting Rated speeds. Also, a bad CPU OC and/or Voltages.

Single Kit (not kits): Set AI Overclock Tuner -> XMP and use Profile 1 in the BIOS, and if necessary VCCSA -> Manual and VCCSA Voltage -> 1.10v~1.20v depending on the kit. Problem some G.KILL's have been using cheap IC's and a harmful to the CPU VCCSA Voltage of 1.25v is often required to keep the kit stable @ Rated.

Q - So again, what exact Kits? ; please provide a link to the kit or kits
Score
0

Best solution

July 5, 2012 2:52:19 PM

Also, make sure your bios is flashed to the current version.
Share
a c 101 } Memory
July 8, 2012 9:26:48 PM

This topic has been closed by Area51reopened
Score
0
a c 101 } Memory
July 8, 2012 9:27:23 PM

Best answer selected by Area51reopened.
Score
0
!