Sign in with
Sign up | Sign in
Your question

Radeon HD 5650 - Screen Rotate

Last response: in Graphics & Displays
Share
March 13, 2011 1:31:56 PM

Hello,

MY notebook is as shown below:

HP Pavilion dv7t Select Edition customizable Notebook PC [Built/Purchased Dec 2010]

* • Genuine Windows 7 Home Premium 64-bit
* • Intel(R) Core(TM) i5-560M Dual Core Processor (2.66 GHz, 3MB L3 Cache) with Turbo Boost up to 3.2GHz
* • 1GB ATI Mobility Radeon(TM) HD 5650 switchable graphics [HDMI, VGA] - For Dual Core Processors
* 8GB DDR3 System Memory (2 Dimm)
* • 640GB 7200RPM Dual Hard Drive (320GB x 2)
* • 17.3" diagonal HD+ High-Definition HP LED BrightView Widescreen Display (1600 x 900)
* • Blu-ray player & Lightscribe SuperMulti DVD burner
* • HP TrueVision Webcam and Fingerprint Reader
* • Intel Wireless-N Card with Bluetooth

Problem:

Started 7 days ago .... When the PC is using the Radeon 5650 Card and I use the keypad including the spacebar the desktop display rotates. To return it to Landscape I have to keep hitting keys or spacebar, or go to the card's property options and reset it to landscape.
Ctr + Alt + Up keys does not rotate the screen.
Problem continues even with Hotkey Disabled.
Problem occurs whether on battery or plugged in.
Does not happen when PC is switched to and using the Intel Graphics.
One more thing, which is odd, it only seem to happen when I am typing/keying in Firefox Browser [v 3.6.14 and v.3.6.15]

HP Tech support spend 2.5 hrs on my PC via remote access and could not figure out the problem.
They said they would research the issue and call me back - that was 4 days ago, no call yet.
I think it may have something to do with FF browser or the card is going bad.
I really would like to permanently disable the Rotate feature at least for now.

Any ideas on a fix for this or how to permanently disable Display rotate?

Thanks for anything that may help.

PCG
March 13, 2011 1:59:23 PM

Try this: You should have the Catalyst Control Center installed with that card. Right click the desktop screen and open Catalyst. Display Manager then on the bottom next to "rotation" click force and then rotation -> Standard landscape. OK.
m
0
l
March 13, 2011 5:54:28 PM

mosox said:
Try this: You should have the Catalyst Control Center installed with that card. Right click the desktop screen and open Catalyst. Display Manager then on the bottom next to "rotation" click force and then rotation -> Standard landscape. OK.


I opened Catalyst Control, then I had under Graphics - Desktop Properties - which gave options to Landscape/ Portrait/ Landscape (flipped)/ Portrait (flipped). When the desktop is normal it shows Landscape selected, when the display rotates it shows Portrait, I select Landscape, hit Apply and it rotates to Landscape.
Problem still persist.

Under Graphics I also have - Display Options - which takes me to a choice for "Display Detection Options".
Also under Graphics there is - Desktop & Displays - which gives me a screen with a blue rectangular box with 1 circled in the center and a black arrow in the top right.
Clicking on that arrow gives me the option to Rotate - Landscape / Portrait / etc.
Nothing gives me the option/choice to "Force" then Rotate.
Problem still persist.

Thanks
m
0
l
Related resources
March 13, 2011 7:59:38 PM

OK, go in the BIOS and look for an option to disable the IGP (Intel Graphics). Those keyboard commands normally work only on the IGP I don't know why they still work on your discrete video card. Disable it and see what it gives.
m
0
l
March 15, 2011 6:13:36 PM

mosox said:
OK, go in the BIOS and look for an option to disable the IGP (Intel Graphics). Those keyboard commands normally work only on the IGP I don't know why they still work on your discrete video card. Disable it and see what it gives.


OK ... I went into BIOS and milled around but couldn't fine an option to disable IGP.
I am not a techie kinda person, and have only seen a Bios screen maybe 2 or 3 times. Hence I am or was lost with your instructions.

m
0
l
March 15, 2011 7:53:17 PM

Look if you have something like Advanced Chipset features, the BIOS is different for each brand. Should be something like "enable if no ext GPU" and disable.
m
0
l
!