Sign in with
Sign up | Sign in
Your question

5970 display issues

Last response: in Graphics & Displays
Share
March 13, 2011 6:13:40 PM

I recently upgraded my Eyefinity system setup from a Powercooler 5850 to a Sapphire 5970, but I am experiencing problems with the miniDP on the card not working at resolutions higher than 800x600 and/or with more than one monitor attached. The history and details of my situation can get kind of long winded. I have a thread about it on the AMD forums that is more like my own running blog on the situation hehe, http://forums.amd.com/game/messageview.cfm?catid=405&th...
most of the details can be found there so I will just summarize here.

I was running an Eyefinity setup for almost a year now using a 5850 card and it was working fine. I recenlty upgraded to a Sapphire 5970 card and now I cannot get Eyefinity to work nor can I get the monitor hooked up to the miniDP to work in resolutions higher than 800x600 or with any other monitor attached.

My current system specs are as follow:
Antec 900 II case
650 watt Antec PSU
Asus Crosshair IV Formula mobo
8 gb Kingston 1600 ram
onboard SupremeFX X-Fi audio
2x WD Sata 500 gb HDD in Raid 0
Sapphire 5970 w/11.2 drivers+CCC
3x Acer H243H monitors - 2 via dual link DVI and one via Bizlink active DVI-DisplayPort+Sapphire DP-miniDP (currently not hooked up)

Prior to getting the 5970 I was running the exact same setup except with a Powercooler 5850 and it ran fine in Eyefinity triple screen display at 5760x1080 rez and with bezel adjusted rez (can't remember exactly what it was something like 6048x1080). I was playing Rift on this setup with the 5850 in Eyefinity ealier the same day I got the 5970.

I went through the correct procedure for unistalling the drivers, then installed the card, then installed the drivers (using 11.2 currently). With this 5970 for some reason the miniDP port will not work at a resolution any higher than 800x600 and it will not work with the two other monitors plugged in; when this is done it causes the other two monitors to switch from 1920x1080 rez to 800x600 and there is still no signal to the monitor running through the miniDP on the card. If I have the two other monitors plugged in via DVI they work fine at 1920x1080 and if I try and plug in the thrid monitor to the miniDP they change to low rez and when I unplug the third monitor from the miniDP the other two monitors revert back to native rez of 1920x1080 and I get the error windows pertaining to DisplayPort link and the monitorwhich people have reported occuring with issues like this. One of the messages is the common message folks have been getting when the DisplayPort adapter cuts out from time to time, I was not experiencing this anymore on my previous setup since I started using a UBS power adapater for the USB plug on the active adapter. Now I am getting that error plus one that reads "The system has detected a problem with the connection between your computer and the DisplayPort display that will prevent youfrom using the highest resolutions and /or refresh rates". This message is new and I have never seen it before.

I have poured over forums and links for days looking fora fix for this; I have tried all kinds of fixes and nothing has worked yet. I have tried earlier dirvers versions like 10.3, 10.4, 10.7, 10.10's etc all the way up to 11.2 and no good. I tried switching monitors around onthe various hookups and that changed nothing. I noticed the cards idle speeds were at really low at 157/300 MHz for GPU core and Memory clocks respectively and 0.9 Volts , so I got MSI Afterburner and used it up the voltage to increase the idle clock speeds. Setting the voltage to 1.0 increased the idle closk speeds to 400/1000 but this did nothing to solve the issue.

I also switched 5970 cards with my dad who also runs a triple screen Eyefinity setup with a Powercooler 5970 and his card worked fine onmy machine and my Sapphire 5970 did the same thing on his setup. And his setup is even kind of bizarre, he uses a no name little DP-miniDP adapter to bridge the hookup from the active DVI-DP adapater to the miniDP on the card and the adapter would not fit between the two DVI cable plugins so he sawed off the screw-in parts on the sides of the DVI plugs so everything would fit. Crazy perhaps, but it worked and his 5970 Eyefinity setup runs fine, while my card is seemingly FUBAR or something...

I am about out of ideas save two that are worst case scenarios.

1) The miniDP on the card is faulty which is a FUBAR situation. I have to send it in to try and get it fixed or try and get a refund on it and hope I can get ahold of a different 5970 that works.

or...

2) The bios on card needs to be flashed/updated. I would hope this is it because I know it can be done, it is just a anxiety-filled, hit or miss procedure that could work and solve the problem, could work and not solve the problem or could brick the card. I am not a stanger to bios flashing, I updated the bios of my mobo not too long ago and it went swimmingly, no problems at all. I have started doing some research on flashing/updating the bios for this card and I have read as many horror stories as I have success stories and mention of complications with flashing to what PCI slot, flashing the master and slave GPU's and improper labling of the master and slave and so on and so forth. Also, I can't seem to find bios downloads for my Sapphire card .

So can anyone help me at all with this problem. Kind of extensive and, so far, unfixable. Is flashing the bios my only option at this point and does the bios sound like it is the problem? I have trouble believing the miniDP port if FUBAR because it gives me output in safe mode and at 800x600 rez. Hoping someone here has some input for me because at this point the frustration and hours/days of looking for anwsers with no results are bringing on a headache of epic proportions.

More about : 5970 display issues

April 4, 2011 11:35:28 AM

Try enabling GPU scaling in the section my flat panels - properties(Digital Flat-panels)

Whitey
m
0
l
!