Sign in with
Sign up | Sign in
Your question

Can't get PhysX to work! (GTX 560 Ti)

Tags:
  • Nvidia
  • Control Panel
  • Drivers
  • Physx
  • Graphics
Last response: in Graphics & Displays
Share
March 14, 2011 9:49:24 PM

Basically, although I have successfully installed PhysX and set it up on the Nvidia control panel, it just won't play.

GPU-Z reports no PhysX hardware
FluidMark shows the PhysX is being done purely by the CPU

I have tried fresh install of drivers several times, including clearing the registry, as well as repairing and silent install.
I have tried the latest beta drivers as well as the drivers included.

Everything else is working fine.

Screenshot:

Spoiler


Any advice would be very much appreciated!

More about : physx work gtx 560

a c 173 Î Nvidia
a b \ Driver
March 14, 2011 10:02:17 PM

Have you tried a clean install of the 267.46's?
a b Î Nvidia
March 15, 2011 12:10:29 AM

I am thankful for my GTX 460 + 8800gt combo. Try older divers for a short time and if you have the ability and a second card on hand you can use that for a short time to get it working then try to switch back but over all try driver cleaner and wipe the drivers. Start clean once again with a different copy of the drivers.
Related resources
a c 469 Î Nvidia
a b \ Driver
March 15, 2011 2:23:20 AM

Uninstalling and reinstalling the drivers is the best option, then making sure that the Nvidia Control Panel is configured properly>Auto (recommended)

ALSO: Make sure you are playing a PhysX game, and that Hardware Physics is enabled in the game settings.

To verify that PhysX acceleration is enabled and working

From the NVIDIA Control Panel navigation tree pane, under 3D Settings, select Set PhysX configuration.

From the menu bar, click 3D Settings, then click the drop-down menu item Show PhysX Visual Indicator.

At the corner of the game screen, the text "PhysX>GPU" or "PhysX>CPU" indicates the type of PhysX acceleration the game is using. If no text appears, then the game is not using PhysX acceleration.
March 15, 2011 5:12:31 AM

Problem solved!

I have a second monitor using DisplayLink (basically a 7 inch USB screen). When switched on, PhysX doesn't work. When switched off, PhysX DOES work!
a c 469 Î Nvidia
a b \ Driver
March 15, 2011 4:50:27 PM

Whew! What PhysX games are you playing?
!