Please help! Not recognizing second 2Gb module!

Hi,
Around September last year, I purchased a 2 x 2gb Corsair 1600mhz Cl9 (see link) DDR3 kit (to replace the current ram) and installed them on an Asus AM3 M4A785TD-V EVO (not USB3) motherboard*.

I installed the modules and entered the timings and voltage (1.65V), and all 4gb were detected in the bios, windows, CPU-Z and SIW. Great!

However, recently, after about 6 weeks of not playing, I noticed a performance drop while I was playing Skyrim. Investigating the cause, I noticed that windows was only detecting 2Gb of ram (this may not actually be the cause of the slow down in Skyrim but this is a problem none-the-less).

So I went into the bios and noticed that all of the ram settings have been set to auto again - so i re-entered them in to see if it helped but no. I have tried each module separately in different slots and can confirm that the modules are not faulty and no one slot is faulty, however, whenever i have both modules plugged in at once, only 2gb is detected. Also, CPU-Z doesnt display the correct timings for the one that is working either.

Please can someone help! I have no idea why both modules are not being detected (all of a sudden almost!), and any advice would be greatly appreciated! Thank you!

-----------------------------------------------------------------------------------------------

* The rig at the time and now consists of a Phenom x4 965, Antec New TruePower 650W (semi modular) PSU, Radeon HD 6870, WD caviar green 750GB HDD. All at stock clocks.

link to ram here:
http://www.corsair.com/memory/intel-memory-upgrades/dual-channel-intel-memory-upgrade-kits/cmx4gx3m2a1600c9.html
9 answers Last reply
More about please help recognizing module
  1. Have you tried using both modules by themselves to cross out that one could have failed? I'm sure you did but just in case. :)
  2. Yeah I've tried both on their own one at a time. I've tried every combination I can think of :/
  3. Put your sticks in same color
    1 - 1s + 2s
    2 - 3s + 4s

    after that see what happend [ bios is default only ]
  4. which os your using [ bit? ]
  5. Clear cmos
    after that if nothing happend try to boot up

    MOBO + CPU + RAM and see what happend ?

    Check another RAM [ Another pc or friend ]

    reseat RAM by cleaning [ carefully ]
  6. Hi thanks for your responses!
    I have tried them in the correct slots for duel channel (as well as one in one colour to check) and I have cleared the CMOS (using the jumper)
    I'm using 64-bit Windows 7 Home Premium. Like I say, I did have all 4Gb working earlier on in the year, so I'm sure its not an installation or compatability issue.

    What exactly do you mean by resetting RAM by cleaning? Maybe I'l give that a go.
    Thanks for your help!
  7. in bios change frequency to 1333mhz for all 1600mhz sticks
  8. reinstall your cpu also
  9. Make your BIOS default just change RAM frequency to 1333mhz as i said above dont oc your ram [ your mobo support 1333mhz only yes you can go 1600mhz but its in oc state ] after that put them in

    1s + 3s
    2s + 4s

    + color mode [ same color ]
Ask a new question

Read More

Memory