Sign in with
Sign up | Sign in
Your question

Can't Add Network Printer

Last response: in Wireless Networking
Share
November 26, 2010 3:35:31 PM

Hello,
We have a Linskys router on a computer that is now running Windows7. It is connected via USB to an all in one wireless printer, and I am trying to connect to it via my laptop.

My laptop is running WindowsXP SP3. But when I try to add the printer, it cannot see it. I have all of the file sharing settings installed, the correct computer names in the SYSTEM tab, my firewall temporarily disabled. Everything. Yet still my laptop just can't find our printer.

I have the correct drivers installed and cannot think what more to do! Someone please help! This has been driving me mad for days now, and I need to get it working!

Very grateful for ANY advice. Thank.x

More about : add network printer

November 28, 2010 1:14:08 AM

is the printer hooked up via USB to the computer or the router? Also which version win7? I will assume pro or ult. This was kind of a b1tch to pull off for me, it was much easier when all pcs were win7, I just dropped them all in the same home group and voila.

There are some not so obvious settings to try:

From the start menu, type advanced sharing, which should show the link for Manage advanced sharing settings. Open this.
On the Home and Work profile settings, make sure your settings look like this as you see the entrys on the page (try at least for a test;if you are scurred of no security, pull the WAN cable from the router, no one can get you)
network discovery on
file and printer sharing on
public folder sharing set to anyone (first option)
password protected file sharing off
Homegroup connections: allow winblows to do it for you.

These settings are how I have mine setup, works for me. The client on XP needs to do the add printer wizard, and you should already have installed the xp version of te drivers on the laptop. If you didnt, thats actually step 1.

Please ask questions if this is too wtf for you.


a b D Laptop
November 28, 2010 1:09:53 PM

The title of this topic has been edited by Buwish
!