Sign in with
Sign up | Sign in
Your question

M4A78T-E and XFX Radeon HD 6450 PCIe problem

Last response: in Motherboards
Share
May 8, 2012 7:05:22 PM

I'm torn between the MB and Graphics forums for this post, but I thought I'd start here and check I haven't misunderstood the MB spec / settings. I've read a few posts and websites about similar issues, but nothing which quite matches my situation.

The card is installed in the blue PCIe x16 slot, and there are no other PCIe cards (or, indeed, PCI cards) installed. BIOS settings are at default for most things, and is latest version (3503). I may have changed the ASPM setting, but I've tried most combinations and nothing changes the results. Catalyst drivers are also at latest version for this card (12.4).

Basically, I can't persuade this graphics card (according to CCC, GPU-Z and HWINFO anyway) to run above x4. Pretty much every tool I've tried reports the same thing, which is some variation on:

PCIe v2.0 x16 (5.0 Gb/s) @ x4 (5.0 Gb/s)

Now, for a start, that looks fishy - why would the transfer rate be the same at x16 and x4? GPU-Z gives the warning that it isn't running at full speed, but the render test doesn't change anything. HWINFO shows these 4 lines against the graphics card:

PCI Express
Version: 2.0
Maximum Link Width: 16x
Current Link Width: 4x
Maximum Link Speed: 5.0 Gb/s
Current Link Speed: 5.0 Gb/s

Soooo, maybe I'm not understanding the PCIe spec very well, but how can the Max and Current show such contradictory figures? And, if you look at the CCC screen capture below, why does CCC suggest that x4 is the maximum setting? Is there something specific I need to do / check on in the BIOS? I haven't actually disabled the onboard GPU, as I'm worried if I total the new card I'll need something to fall back on to see the BIOS screens, rather than having to physically remove the new card.

Now, I realise from reading around this that in fact I probably won't see much performance change if I did get this card to run at x16, given that it's not exactly a top-end GPU. However, I'm interested for the sake of learning and ensuring I am getting the most I can out of the system.

Is there anything else I can do, other than try the AMD graphics card forum?

Thanks,

Dave

CCC Info Panel:


HWINFO Summary:


GPU-Z:
May 9, 2012 2:29:53 AM

there is a messed up setting some place. have you tried your other PCI-E slot?
a b Ĉ ASUS
a c 118 V Motherboard
May 9, 2012 3:14:52 AM

first go to the bios and set pci-e as first graphic card use your motherboard manual how to do it,card goes in the first pci-e slot just below cpu and set your ccc to advance mode then post back result( i am using the same motherboard)
Related resources
May 9, 2012 9:56:43 AM

@ncc74656 - I was hoping to not have to open the case again, as the machine is pretty inaccessible when cabled up... Ho hum, I guess I'll have to. I know the other slot is limited to x8, but even that would be an improvement :)  I'll post back later today when it's done.

@scout_03 - PCI-E is already set as the first card, and the card is in the first slot (the blue one). CCC (Catalyst Control Centre?) is in advanced mode (see first screenshot from OP) - not sure what result you were referring to?

Thanks all,

Dave.
May 9, 2012 10:31:45 AM

@ncc74656 - quick swap of the slots put the card up to x8 in the second PCIe slot. Moved it back to the primary slot, and it went down to x4 again. :( 

I'll capture some BIOS settings later to see if there's anything in there that's not right - but as far as I could see, all the PCIe ports were all set the same.
a b Ĉ ASUS
a c 118 V Motherboard
May 9, 2012 6:11:32 PM

your card is working at the minimum settings in cpu-z your memory speed is at minimum specs and the same for default clock also the bandwidth .you use xp that why your panel was not the same i got
May 9, 2012 6:42:17 PM

well 8 is better than 4 but you have a setting off some where. every time ive run into this type of issue its been a bios setting
May 10, 2012 8:54:03 AM

I spent last evening working through the approximately 1 million BIOS combinations (may have exaggerated a little there), taking photos of the screen at every step in case that would help track down the setting that was causing the problem. I even managed to resist the urge to change several things at once. Eventually I just disabled the on-board graphics card, et voila, the 6450 came up at x16. Great, I thought, but before I post a success message to the forum, I'll just prove that was what caused the problem by re-enabling it. And you can probably guess that now I can have the on-board graphics enabled and the 6450 still runs at x16. In fact, my BIOS is now configured exactly as it was when I started, and the 6450 is doing fine. Grrr. But at the same time, woohoo!

So, I guess it could have been a BIOS thing which needed the on-board graphics to be cycled off and on to sort itself out, or perhaps the 6450 was always running at x16 and the monitoring software was just reporting it wrong. Who knows. But anyway, thanks for the tips, and perhaps this will help someone else at some point.
May 10, 2012 9:05:04 AM

Also, sorry - I think I should have started this post as a Question, but I only just noticed the different types whilst trying to work out how to add [Solved] to the title... Oops!
!