Can't copy files to my removable disk(s)

Hi.. I need your help.. I'm having problem with copying files into my removable disks (microSD and SD).. Transferring files FROM the removable disks is working fine but transferring TO them is somehow problematic.. both cards were empty as I had just formatted them before copying.. I do not use any transferring software like teraco**.. I use CTRL+C and CTRL+V..

I'm using windows 7 ultimate on a core2duo with 1GB RAM

copying small number of files is working fine.. but when I tried to copy around 22 files, the transfer stuck at 7 files remaining.. By now, it has been half an hour since it's stuck.. (I'm transferring 22 files with total size of 1.15mb so I don't think it has anything to do with FAT32 thing..).. I have also tried to transfer other files..

I've tried transferring different kind of files using card reader and data cable from my cellphone.. I've also tried to use VirtualBox (running windows XP) to transfer the files.. all of them are not working..

Please help me..

Thanks in advance,
9 answers Last reply
More about copy files removable disk
  1. Not sure on the hang up with copying but you need some more ram in there man,
    I'm praying that your running 32bit win7?
    you seriously dont want to be trying to run 64bit on one Gb ram lol
    Moto
  2. yes it's 32bit.. :)
  3. Try different USB port for your reader.
    Make sure the card's connections are rigid
    I would suspect the quality of the cards. Try formatting them with Windows, not a quick format, a full one and then also run a scan disc. If they are bad just throw them away and buy new ones.
  4. More information needed. What is the size of the SD cards? If they are larger than 2Gig you could be having problems with them not being compatible with your card reader.
  5. darkguset, I have tried every USB Port on my CPU.. and yes I have tried full format and scan disk.. I have also tried some flash drives but none of them are working..

    pjmelect, the microSDs are 2gb and the SD is 8gb.. I use transcend p8 card reader..

    please help..
  6. I am at a bit of a loss to explain your problem, have you tried disabling your anti-virus program or firewall program (if installed)?
  7. yes I've tried that.. It doesn't help..
  8. found the culprit.. I have a webcam connected to one of the USB Port.. I removed it and everything went well.. I guess it is power problem..

    Thanks for everyone's help.. I really appreciate your efforts to help me.. :)

    Cheers!
  9. Well we learn something every day too!... lol :)
Ask a new question

Read More

Removable Disk Components