Sign in with
Sign up | Sign in
Your question

MB BIOSTAR TZ77A compatability problem?

Last response: in Memory
Share
May 9, 2012 12:38:50 PM

Hi Guys,
I ll post my problem here, because it is very similar.
I just upgraded with new MB, CPU and RAM and it doesnt boot up at all.
MB is the same as the previous person: BIOSTAR TZ77A
Cpu is: i5-3570K
The ram is: Corsair Vengeance 4 x 4GB PC15000 DDR3 1866MHz CL9 .
PSU: ULTRA 550w, CORSAIR 450w (tried with both).
And yep, I know it is not on the memory supported list. In the rush I skipped checking. Still I'm hoping its compatable.

So the problem is the system doesnt want to power on at all. Just the fans move for parts of the second.
I tried (possibly) all combinations. 4 sims inserted, 2, 1. When 2 in the white, in the red, or 2 by 2. Anything.
The mem is 1.5v.

Since the system doesnt boot up at all, and the sound doesnt give any error code, I really dont have much what to do with it.
No bios updates, no playing with voltages.
I really need to know fast which one is the faulty hardware (or incompatable), to see what to do with these parts. Return, buy new, or what ...
Needless to say, its frustrating to spend 700$ on parts that do not work.
Sent an email to Biostar support, but I doubt it they ll give me some precise info.

p.s. I attempted to boot with only CPU and RAM, plugged montitor to one of the onboard video ports.
Even tried without plugged in monitor at all. MB should still boot up. Not sure if there is no RAM modules at all. Should the system power on?

I am considering buying cheap DDR3 ram, just for testing. Something around 20-40$.
Ill probably do it. But there is no guarantee it will work either.

Also another small concern is,
Even if these MB are brand new, with Z77 chipset, is it possible to be specifically flashed with bios for generation 2 - sandy bridge.
On the MB website says that they support by default ivy bridge, and with a BIOS flash, they would support sandy bridge.
But is it possible, these specific 1st MBs that are on the market, to be the opposite. And be flashed with another bios for generation 2. On tiger direct website, in the description, they say it supports Genration 2 - Sandy bridge.
But on the other hand, in the MB manual, and even printed with big letters on the board itself, says 22micr CPU.
I bought MB & CPU, just 2 days after ivy bridge came out, this is my concern.

Another info,
I did a small research. It appears that my RAM, defaults to 1333mhz and certain default voltage when initialy boot up.
To prevent incompatabilities. Then only manually it is set differently.
This is at least something ....

Many thanks for the help in advance. I am building systems for 20 years now. And I knew it in advance that you never know with new hardware.
... and also when you a striving for the cheaper solution ... that makes things harder also. (thinking the MB here)
a c 81 } Memory
May 9, 2012 2:45:30 PM

the mb has a post it led to tell you if it posting. check to see if it going ff or nothing on it. if nothing is on it you may have what called a dead short. ps and mb wont post if they see a dead short. it could be the i/o shield or one of the stand offs or the cpu cooler is hitting the mb tray and shorting out.
May 9, 2012 3:09:12 PM

Hi,
thanks for response,
I am at work now, and I can look at the MB in 5-6 hours.
The led stayed off all the time. Nothing was displayed. Also no sound for an error code. (I attached speaker).
For now the MB is not attached to any case. Does it have to have separate grounding? Also the only fan attached is the CPU fan. I was thinking there might be a safeguard, but it doesnt make sense for anything else than the cpu fan.

Also the CPU fan comes from intel with the CPU box. The radiator is not big at all, and I dont think it touches anywhere. It makes good contact with the CPU surface. Not too strong and not too soft. I thought about possibility of safeguard for CPU temp, but I dont think its the case.
The symptom is like from a broken PSU. Or not powerful enough. But I dont think this is the case either.
But might be incompatable. This will surprise me. ULTRA is a very good brand (I think). I tried 450w corsair also.
I tried only with CPU, ram and MB, to rule out the power unsufficiency.
Thanks Again.
Related resources
May 9, 2012 10:35:08 PM

Give it a try with the CPU and only one RAM stick connected (and the CPU cooler of course). Be sure you have all drives and add-on cards disconnected. If the result is the same then my first guess is that the CPU is bad, and second guess is the motherboard.

I'm assuming that you know for a fact that at least one of the PSUs is good (tested on another system)?
May 9, 2012 10:36:23 PM

Problem is solved.
I havent attempted to install windows, but for now the system boots up.

The forum helped.
I just browsed 2-3 topics and I encountered this link:
http://www.tomshardware.com/forum/261145-31-perform-ste...
Listed as point one, stroke me as a lighting.
"Did u plug in the CPU power connector which is close to the cpu"

Somehow I got the assumption that the newest MB& CPU do not need one. Because there are more pins on the main PSU connector.
And the older designs never had one, before P4.

Yep, I know it is banal. And I am so happy everything works. I dont have to RMA or buy new components or other crap.
Still no response from Biostar and Corair. But even if they've responed, I doubt it would've been useful.
Anyway thanks!
!