Sign in with
Sign up | Sign in
Your question

X58A-UD3r Rev2 - Unable to see eSata ports; JMicron drivers installed

Last response: in Motherboards
Share
May 9, 2012 2:09:20 PM

I have a PC containing a Gigabyte X58A-UD3R rev2 motherboard running Windows 7 Professional X-64. I have recently upgraded one of the internal disk drives to a Crucial 128Gb SSD and as part of the upgrade I reinstalled Windows 7. I also updated the Bios to the current one on the GB site (version FH).


The ports I am using are:

Intel Port 1: SSD
Intel Port 2: Data drive (1Tb Maxtor Sata II drive)
Intel Port 3: Other data drive (for backup) (2Tb WD Sata II drive)
Marvell Port 1: DVD/RW Drive
Marvall Port 2: DVD/RW Drive

(I installed the two DVD drives on the Marvell Ports as these were not recommended for the SSD by other posters on this forum, and because the first time I tried to use a drive connected to one of the rear eSata ports it was not seen by the PC, and I moved the DVD drives to the Marvell ports in case having 5 devices on the internal Intel Sata ports was the cause of the problem - which it probably wasn't).

I installed the latest drivers and chipset from the GB site.

I have set the Intel SATA ports to AHCI, but left the other ports, including the GSata ports, as IDE.

I am trying to connect to a external Sata drive which is located in a Sharkoon data caddy and connected by an eSata cable. The caddy is externally powered.

Before I upgraded to the SSD and reinstalled Windows, I was able to see the external drive without problem.


When I first encountered the problem, I searched the web and found that I hadn't installed the JMicron drivers (as I didn't see them on the GB website). So I downloaded the latest drivers (JMB36X_WinDrv_R1.17.63_WHQL_eSATA) from the JMicron website and installed them.

I am still unable to see the external drive.

I have tried booting up my PC with both the external drive switched on, or switched off and then switched on after the boot has completed - I was unable to see the external drive.

I have checked the Device Manager and I can see that there are two JMicron JMB36X Controllers listed under Storage Controllers. Both devices are supposed to be working properly.

With the external caddy/drive switched on I scanned for new hardware - none was found.

Also during the boot sequence, and with the external caddy/drive switched on, I can only see the 3 internal drives (1 SSD and 2 HDD) listed.

Can anybody else advise what I might try?

Many thanks in advance for your help.
a c 121 V Motherboard
May 9, 2012 3:17:35 PM

I am assuming that the eSATA controller is set to Enabled, and the eSATA Ctrl Mode is set to IDE?

Edit: Settings in the BIOS.
May 9, 2012 3:55:11 PM

Yes. eSata controller set to Enabled and Ctrl Mode set to IDE

(Having problems posting a reply as keep getting "Sorry Forum not available message")
Related resources
a c 121 V Motherboard
May 9, 2012 4:06:51 PM

This is a long shot, but are there any BIOS updates available?
May 9, 2012 4:36:38 PM

I have already installed the latest BIOS (version FH) when I rebuilt the OS after installing the new SSD.
a c 121 V Motherboard
May 9, 2012 5:18:55 PM

I'm pretty much at a loss.

I know on my board (Asus) the eSATA has to be plugged and powered on prior to powering on the computer. But you mentioned that you tried that.

I would suggest calling up Gigabytes Technical Support. They are usually pretty good.

Sorry I couldn't help more.
May 9, 2012 5:40:16 PM

itzdanielp: thanks for your help. I have opened a ticket with Gigabyte; unfortunately they don't seem to have telephone support in the UK.
a c 121 V Motherboard
May 9, 2012 5:47:57 PM

Hopefully you will hear back soon. It's kind of lame that they don't have phone support for you guys over the pond. :/ 
May 10, 2012 8:10:15 AM

Problem solved!

Believe it or not it turns out to have been a broken eSata cable. It must have become broken somehow when I was putting in the new SSD. A different eSata cable solved the problem and all now appears to be working.
a c 121 V Motherboard
May 10, 2012 2:25:46 PM

haha, sometimes it is the simplest of things :) 

Enjoy!
!