Sign in with
Sign up | Sign in
Your question
Closed

HDMI looks worse than VGA ??

Last response: in Graphics & Displays
Share
March 18, 2011 10:42:21 AM

I am sure there has been plenty of these questions around here, in fact, I have searched and tried things and nothing has worked that I have seen just yet.

GPU: Radeon HD6850 Black Edition

I just installed this video card last night, when I got home I wanted to plug it up to my HDTV.

HDTV: Samsung - 40" Class / 1080p / 60Hz / LED-LCD / 5000 Series

The problem I am having is this. When hooked up to my TV with VGA, the picture is 95% perfect - 1920x1080 @ 60Hz -


When hooked up with HDMI - 1920x1080 @ 60Hz, the fonts look terrible, and some of the picture is just too intense. Sort of like this -
(I just zoomed the screenshot in to resemble as best I can of what the image looks like while using HDMI)


I have the drivers from the AMD website installed. I have played with the Hz settings, game mode on TV on/off, set the presets from dynamic to standard, different HD formats from 720 through 1080, scaling and not scaling, etc.

I did notice however that in CCC, it recognizes my TV as being 1920x1080 @ 75Hz, and as stated above, the TV is stating 60Hz. I don't know if that has anything to do with it, but just giving as much information as I know to give as of now.

If there is anything else I should look for or try to change, I invite suggestions.

More about : hdmi worse vga

Best solution

March 18, 2011 11:23:42 AM
Share

Looks like a scaling issue.

TV moniters and PC moniters display digital images slightly differently [I won't go into exact details]. As such, if your TV is not aware its taking in a PC input, the image will look like crap.

As an example, my Samsung UN46C7000 (7000 series) allows for named HDMI inputs. If I don't specifcally set the name of the HDMI input for my PC to "PC", the image that results is very simmilar to what you are getting. When the input is set to "PC", the image is crystal clear. Thats probably whats happening in your case as well.
March 18, 2011 11:24:51 AM

Thanks! Solved it. Did not see the Tools option in the source menu or I am sure I would have played around in there. Just had to set my HDMI/DVI 1 port to "PC" ... now it works flawlessly!!!
Related resources
March 18, 2011 11:25:17 AM

Best answer selected by NTCosa.
March 18, 2011 2:17:00 PM

^^ NP; I had to screw with the image settings within Windows for a while before I figured it out myself.
July 10, 2011 1:00:17 AM

gamerk316 said:
Looks like a scaling issue.

TV moniters and PC moniters display digital images slightly differently [I won't go into exact details]. As such, if your TV is not aware its taking in a PC input, the image will look like crap.

As an example, my Samsung UN46C7000 (7000 series) allows for named HDMI inputs. If I don't specifcally set the name of the HDMI input for my PC to "PC", the image that results is very simmilar to what you are getting. When the input is set to "PC", the image is crystal clear. Thats probably whats happening in your case as well.



THANK YOU!!!!!!!!!

I though something was seriously wrong with my monitor. It looked good on VGA mode, which defaults as the listed PC Mode. But whenever I hooked in an HDMI cable it looked like the OP's desktop. After months (literally) of searching I finally found this post. Took all of 10 seconds to edit the HDMI 1 port to a PC signal input.

Damnit I really appreciate it!

My Samsung B2330HD is now getting used properly for the first time since I purchased it!
!