Sign in with
Sign up | Sign in
Your question

PSU or Motherboard failure?

Last response: in Components
Share
August 23, 2011 4:54:27 PM

Today I built my first computer i followed all of the instructions on a HAF 922 building demonstration. When I tested my motherboard and psu outside of my case everything worked fine. The fan on the PSU turned on and the motherboard LED did as well. Then i proceeded to put my motherboard in my case followed by CPU the ram then CPU heat-sink and finally the graphics card i plugged my CPU fan into the four pin connector. I then tested to see if everything wold turn on the CPU fan as well as everything else turned on. After the test i plugged in the rest of my components. When I did my final test the system was completely dead no fan or LEDs turn on. Is it a defective motherboard or PSU I have RMAed my motherboard and the second one did the exact same thing.

Please help

Specs
HAF 922
Biostar TZ68A+
Coolmaster 212
MSI 560ti twin frozr
Antec Earthwatts Green 650W Power Supply
8gb G.SKILL Ripjaw
Crucial M4 SSD Micron C400 64GB 2.5IN Solid State Disk Flash Drive SATA3 6Gbps
Seagate Barracuda ST31000524AS 7200.12 1TB SATA 32MB Cache 3.5IN Internal Hard Drive OEM
LG GH24LS70 24X SATA Lightscribe Internal DVD Writer Burner DVDRW Optical Drive Black OEM
a c 139 à CPUs
a b V Motherboard
August 23, 2011 6:57:56 PM

Double check connector and short circuit behind black plate motherboard catch case .
m
0
l
August 23, 2011 9:37:46 PM

henydiah said:
Double check connector and short circuit behind black plate motherboard catch case .

How do i check for short circuit?
(thanks for help)
m
0
l
a c 139 à CPUs
a b V Motherboard
August 24, 2011 2:29:55 AM

Remove motherboard from the case, put the plastic under the motherboard to protect the black plate with Case contac mobo.
m
0
l
!