Motherboard HELP - Please

I bought the ASRock Z77Extreme4 motherboard on newegg for 140$ to support my new i5-3570k. Installed everything in my case last night, and when we turned on the comuter I got the dr.debug error on the motherboard reading error code "55". Looked it up, said it was a problem with the memory, we switched out the slots, and eventually tried every slot with one RAM stick. After no avail on that, I switched to another RAM that was in my older computer that I know works and still read the same error. We switched out even the power supply, not exactly knowing the issue.

I tried to get a hold of the tech support for ASRock but there almost non existent. Could anybody know what this error means if it's not working even after I change out memory and what not? Could I have gotten a faulty board?
5 answers Last reply
More about motherboard please
  1. I can't even get to the bios - it doesn't post.
  2. Doubtful you got a faulty board.

    Please list your system specs.
  3. I got the asrock z77 motherboard extreme4. Ivey i5 3570k gskill 2x 4gb 1600mghz. 600w power supply cooler master. 550ti 1gb nvidea geforce. Plus I got a cpu cooler for the cpu and a cheap dvd drive. Oh and a western digital 1tb harddrive
  4. Even still it posts dr debug error 55 with almost replacing every part in the pc damn near. I don't get it
Ask a new question

Read More

Motherboards Support ASrock