Sign in with
Sign up | Sign in
Your question

High Pitched Noise around CPU area

Last response: in Motherboards
Share
May 11, 2012 5:30:06 PM

HI guys i am having the same problem as most in her in this thread http://www.tomshardware.co.uk/forum/292915-12-high-pitc...

I have

i5 2500k - Not overclocked & Stock Cooler
P8z68-v/Gen3
Windows 7 64 bit

Alot of Asus boards seems to be getting this after a few google searches.

I have narrowed it down to the power saving options. When i disable c3/c6 in the Bios then the sound stops

I also do not get the sound when i am in the Bios and while the Machine is booting up. It is only when the windows Login screen pops up it starts. Again as others has said, under load the noise stops too.

Im not to comfortable disabling the c3/c6 in the bios as it makes the cpu run at a constant 3.7ghz and makes my temps around 50C at idle and with the stock cooler.

Im not really sure what to do now, would really appreciate if anyone could give me any advice.
May 11, 2012 5:47:47 PM

Thanks for moving my Post Nikorr, but you got the Title wrong.

I am not getting the sound in the bios or boot, its only when i am in the OS i'm getting the sound

and just so people know when they look at this thread, im referring to this thread in my OP http://www.tomshardware.co.uk/forum/page-292915_12_50.h...
m
0
l
a c 328 V Motherboard
May 11, 2012 5:51:40 PM

OK, just so u know, u can change the title by yourself anytime.

After all it is your thread now : )

/Click on the EDIT feature to change the title, not the Quick Edit./

Good luck!
m
0
l
Related resources
May 11, 2012 5:55:54 PM

nikorr said:
OK, just so u know, u can change the title by yourself anytime.

After all it is your thread now : )

/Click on the EDIT feature to change the title, not the Quick Edit./

Good luck!


I did try to edit it, but i get a message saying "you are not allowed to edit this message" :/ 
m
0
l
a c 328 V Motherboard
May 11, 2012 5:57:14 PM

OK, post it bellow and I will place in your changes.

m
0
l
May 11, 2012 6:05:09 PM

Thanks

High Pitched Noise around CPU area

HI guys i am having the same problem as most in her in this thread http://www.tomshardware.co.uk/forum/292915-12-high-pitc...

I have

i5 2500k - Not overclocked & Stock Cooler
P8z68-v/Gen3
Windows 7 64 bit

Alot of Asus boards seems to be getting this after a few google searches.

I have narrowed it down to the power saving options. When i disable c3/c6 in the Bios then the sound stops

I also do not get the sound when i am in the Bios and while the Machine is booting up. It is only when the windows Login screen pops up it starts. Again as others has said, under load the noise stops too.

Im not to comfortable disabling the c3/c6 in the bios as it makes the cpu run at a constant 3.7ghz and makes my temps around 50C at idle and with the stock cooler.

Im not really sure what to do now, would really appreciate if anyone could give me any advice.
m
0
l
a c 328 V Motherboard
May 11, 2012 6:21:03 PM

The title of this topic has been edited by Nikorr
m
0
l
May 12, 2012 6:54:29 PM

Managed to fix the problem.

It was the c6 state to be specific. Before it was set to C1E Auto, C3 Auto, C6 Enabled.

I set C6 to Auto, This stopped the whine, but this make the SpeedStep feature not work and the CPU was running at a constant 3.7ghz

So i Disabled C6 and changed C3 to Enabled and the whine has now gone, with the Speedstep feature working fine
m
0
l
January 25, 2014 9:45:42 AM

Hi,

I have the same noise problem with my Laptop. However I cant reach c-states in BIOS. They are not listed there.
Are there any alternatives for changing c-states to BIOS?
Dell Precision 4500m
CPU: i520m(should support c1, c3,c6)
m
0
l
April 20, 2014 5:54:30 PM

Hello to everyone who suffers from the so called "CPU whine noise" that appears when CPU is idling. I know that this is an old thread, but so many people are still having the same issue that I just have to post this.

I've also been experiencing the same problem and after many of nightmarish hours I've finally found the solution that actually WORKS!!! :) 

Just for your information:
Forget about the "Processor idle disable" option... Even though it makes the CPU idle (whine) noise go away, it will also make your CPU temperatures go high and the fan will be spinning like crazy + the battery will drain faster.

If the trick with Microphone works for you, fine... but for me and many others it did not help at all.

What you actually need to do is:
1. Follow the steps written here:
http://forum.notebookreview.com/solid-state-drives-ssds...

2. THIS STEP IS CRUCIAL:
Change the Processor idle promote threshold from 95% to 100% (!) This additional tweak killed the CPU noise/whine (when idling) for my computer completely.

Don't worry if you don't have an SSD! (I have an Asus N56JR laptop without an SSD and it works great)

The noise was driving me crazy and this is the ONLY and THE BEST solution that actually worked for me :)  Give it a try, you can always reverse the changes... Please let us know if it worked for you too.

BTW: enjoy the silece ^^
- ins0mni4c7
m
0
l
April 23, 2014 8:08:42 AM

ins0mniac, I tried these options but they didn't work with me! Could you help me, for christ's sake? The noise kept going in idle, even if I did all the options above. Did you disable C1, C3 or C6? Or speedstep? What's the options you have in BIOS? My settings: Asus P8B75M LX PLus, i5 3330, 8GB ram Kingston, GTX 650. The noise is the same as Biggs87, I can't listen to it in BIOS or when booting up, only when dekstop appears and forth on
m
0
l
April 23, 2014 2:51:34 PM

Hmm, that's strange... and sad :( 

Someone (aeonax) posted on This Forum (last post) that he tried the steps written above and that it worked for him too. I never changed any of C1/C3/C6/SpeedStep because all these settings are "invisible/blocked" in my BIOS so I had to find other ways to disable the stupid noise...

You can try to set "Processor Idle Disable" to "Disable Idle" - Follow Instructions Here (also READ the comments, there are some other possible solutions). But what this will do (as you could probably already figure out); it will prevent your processor to enter "idle mode", so it will always be performing more as it should - it will start to heat up, the fans will start to spin fast and it will drain more battery (as I already mentioned in previous post)... but it should make the noise go away. My opinion: still a bad decision... :( 

btw: have you tried Biggs87's solution?
m
0
l
April 24, 2014 1:06:14 PM

Hey ins0mniac, thanks so much for you reply!
Yeah, actually the only way to make the noise go away was doing the Disable Idle thing. I'd like to know if it will make my bill energy increase lots more than if I stayed with the noise?
I tried some things, like disabling C states and speedstep, but they didn't seem much effective.
Also, if you figure out any other methods, just let me know!

PS: I'm using a desktop
Thanks!
m
0
l
April 26, 2014 9:04:40 AM

Hey Galinho13 no problem. :) 

I'm not so sure about the electricity bill, unfortunately you will have to figure that out on yourself, sorry...
BUT... I DID FIND ONE MORE SOLUTION haha! :D 

- Go to Control Panel and find Power Options. Click Change Plan Setting and then Change Advanced Power Settings.
(- Then first of all reverse the changes if you made them - put "Processor Idle Disable" to "Enable Idle")
- Expand Processor Power Management and then CHANGE Minimum Processor State to something like 10-50%. Basically just keep making it higher until your processor will stop making idle whine/noise sounds. ^^
*Edit: if you have more than one power options profile, make sure to apply the changes to all of them.

Keep in mind that this will also make your processor not perform lower than you set it. So it will "burn" little more power, but the noise should go away. Hopefully this solution will work for you as well!

Please let me know about the result. :) 
- ins0mni4c7
m
0
l
!