Sign in with
Sign up | Sign in
Your question
Closed

Really odd performance issues with my RADEON HD 6950

Last response: in Graphics & Displays
Share
March 19, 2011 8:07:08 AM

I recently bought a RADEON HD 6950 (ASUS EAH6950) and have been using it quite a lot in the short month ago that I aquired it - my question is this; What is this really odd performance issue I'm having with this card? When I put a game up such as Battlefield: Bad Company 2 - I get really weird things... 1.) When I load into a game half of the time I get a greyed out background and can only see my HUD (pick my role and my equipment). Also when I first get into a game 90%~ of the time it freezes up for seconds at a time then it goes right back to 60 fps solid (all of this is with the settings maxed out, 8x MSAA and I believe 16x AA - whatever the highest settings are I set them to) because I've seen from this sites review and several others that this card can handle it with virtually no problem and maintain superb performance.

I tried re-seating the card (I rebooted the computer after every change and after every reverse for comparison), then I tried re-seating the RAM, followed by removing the RAM and trying different RAM in the computer all together, followed again by putting the card into another tower to see if it was simply something else causing it, then last but not least I of course tried dating back the drivers all the way back to default for the 6950, then I tried updating back to the newest ones... Absolutely no change in performance in any of these things.

Along with some really odd rendering line (I find it hard to explain what this line is... but to be honest it looks like maybe about 100 feet infront of my character in almost EVERY game I play has some sort of really messed up blurred line) that constantly moves when I move and always stays the same distance from me no matter what. For example I was playing Metro 2033 and when I was in the Moscow level (the 2nd time to go to the surface) I looked up at the buildings to admire the graphical detail and what do I find? A messed up looking shadow line that is supposed to be forming from the building covering the one I was looking at in a shadow. Instead when I moved around and looked at the building the shadow moved with me and raised up and down the building front when I got closer for farther away. In BFBC2 I can see a line around 100ft in-front of me (everything inside the line looks great and supreme detail) but anything outside of the line gets blurred and really shadowed looking.

I've also noticed in some games that certain graphics will start to glitch over each other (for example I would be running around and on the ground a mount of dirt would dull out and be sitting on some concrete - and at the edge where the graphics meet they kind of glitch and try to go over one another giving it a twitching motion back and forth between the both of them). I've found that out recently with the game Homefront which just came out...

I'm at a loss for what to do and all I can think of is maybe it's the cards internal RAM that could be causing it... And yes I tried tinkering with CCC (Catalyst Control Center) to adjust the performance of my card and maybe rid myself of these problems - and that did nothing but make the artifacts worse and definitely more noticeable. Any advice would be amazing - because it would seem I'm having a really hard time trying to find someone else with the same problem... And of course here's my system specs.

ATI Radeon HD 6950 (ASUS EAH6950 2gb)
AMD Phenom II x6 1100T (Thuban Black Edition Hex-core)
16gb of 1333mhz RAM (G. Skill RipJawz edition)
1TB Western Digital HDD (7200 RPM 64mb buffer)
64gb SSD, OCZ brand
Windows 7 Home Premium
Cooler Master 1000W 80 gold series PSU

Thanks again for looking over my question and I apologize for the horrid grammar, it's late and I open in the morning but this is keeping me up all night worrying about this.

-Ron

Edit: Added my PSU to computer specs.
March 19, 2011 8:47:51 AM

Since nothing looks wrong with the computer set-up you got i suggest it might be a driver issue... Try tinkering with the latest driver or if that doesnt work try installing fresh with your cards default drivers (the cd that came with it). Maybe a clean installation might help? Is it an upgrade or a freshly installed windows setup? Try driver cleaning your system. If all else fails then maybe we are talking about a faulty gpu? Have you noticed anything about unusual temps or too much noise or no noise at all from the fan?
Score
0
March 19, 2011 9:35:42 AM

SakujouKuroi said:
I recently bought a RADEON HD 6950 (ASUS EAH6950) and have been using it quite a lot in the short month ago that I aquired it - my question is this; What is this really odd performance issue I'm having with this card? When I put a game up such as Battlefield: Bad Company 2 - I get really weird things... 1.) When I load into a game half of the time I get a greyed out background and can only see my HUD (pick my role and my equipment). Also when I first get into a game 90%~ of the time it freezes up for seconds at a time then it goes right back to 60 fps solid (all of this is with the settings maxed out, 8x MSAA and I believe 16x AA - whatever the highest settings are I set them to) because I've seen from this sites review and several others that this card can handle it with virtually no problem and maintain superb performance.


This is a normal thing, i got a 5770 and at times i also get in with a gray background and i also get the freezes in the start, but i think it only happens in the start as it loads the hole map area, building, terrain, broken things, vehicles, ect

SakujouKuroi said:
Along with some really odd rendering line (I find it hard to explain what this line is... but to be honest it looks like maybe about 100 feet infront of my character in almost EVERY game I play has some sort of really messed up blurred line) that constantly moves when I move and always stays the same distance from me no matter what. For example I was playing Metro 2033 and when I was in the Moscow level (the 2nd time to go to the surface) I looked up at the buildings to admire the graphical detail and what do I find? A messed up looking shadow line that is supposed to be forming from the building covering the one I was looking at in a shadow. Instead when I moved around and looked at the building the shadow moved with me and raised up and down the building front when I got closer for farther away. In BFBC2 I can see a line around 100ft in-front of me (everything inside the line looks great and supreme detail) but anything outside of the line gets blurred and really shadowed looking.

I've also noticed in some games that certain graphics will start to glitch over each other (for example I would be running around and on the ground a mount of dirt would dull out and be sitting on some concrete - and at the edge where the graphics meet they kind of glitch and try to go over one another giving it a twitching motion back and forth between the both of them). I've found that out recently with the game Homefront which just came out...


this could be a driver problem or the card itself, i suggest download the latest ati driver, uninstall your current one, run Driversweeper and then install the new driver. If this doesnt work replace the card


SakujouKuroi said:
ATI Radeon HD 6950 (ASUS EAH6950 2gb)
AMD Phenom II x6 1100T (Thuban Black Edition Hex-core)
16gb of 1333mhz RAM (G. Skill RipJawz edition)
1TB Western Digital HDD (7200 RPM 64mb buffer)
64gb SSD, OCZ brand
Windows 7 Home Premium
Cooler Master 1000W 80 gold series PSU


Your specs are more than enough to handle this card and any games.
Score
0
Related resources
March 19, 2011 3:29:37 PM

Thanks so far guys - but alas I tried everything with the drivers too. I ran driversweep and removed all driver components... I did a fresh install with the cd drivers and it didn't fix it. Then I tried the 2nd released drivers, still nothing then of course the newest set :/ 
Score
0
March 19, 2011 3:41:53 PM

You may simply have to wait till new drivers come out, I have had to do this in the past and it is Very frustrating so either try different games or pick up a spare card from nvidia or a older ati card to use for the affected games then once done do a swap. That is why I always keep both brands on hand knowing that ware one fails the other will more than likely pick up but when they both do not with the latest drivers I am quick to blame the game.
Score
0
March 19, 2011 3:46:57 PM

Well I contacted Asus and they said I can RMA the card, I would just prefer to not have to. Am I wrong in thinking it could be the video RAM?
Score
0

Best solution

March 19, 2011 3:50:03 PM

Possible but there would also be arctifacting as well if it was the vram. Just go ahead with the RMA and see how things go from there.
Share
March 19, 2011 3:52:57 PM

Best answer selected by SakujouKuroi.
Score
0
March 19, 2011 5:04:34 PM

Quote:
did you enable vsync and tripple buffering


No I've not tried it yet, I always have V sync on though. Otherwise I get horrendous screen tearing. Could triple buffering remove or minimize the weird rendering line thing?
Score
0
March 19, 2011 8:24:48 PM

Alright, I tried setting the Triple Buffering and still nothing :[ although the graphic overlaying isn't there anymore but the really weird rendering line is still there, and I'll post some links to show you what I mean... I took some screenshots from in-game.



Score
0
March 19, 2011 8:40:34 PM

So yea that's what it looks like (I know it's hard to see) but if you look closely at the highlighted areas... You can really tell the difference in the lighting and that was with me only moving a slight tap of a button left in each picture. I would get some pictures of Metro 2033 but I'm trying to refrain from pushing the card too much until I get the RMA return box.
Score
0
August 23, 2011 7:12:47 AM

SakujouKuroi said:
So yea that's what it looks like (I know it's hard to see) but if you look closely at the highlighted areas... You can really tell the difference in the lighting and that was with me only moving a slight tap of a button left in each picture. I would get some pictures of Metro 2033 but I'm trying to refrain from pushing the card too much until I get the RMA return box.


I bought 6950 too, and i got same problem, the game was runing fine but now i got same lag, freeze at start issue as you, i was trying same as you changing catalyst settings, in cata ive just changed power control +20%.. tried fresh instal of windows.. but still the same. Sometime it freezes even in game fan slows down, after several sec it starts running again but some servers autokick players with high pings, so i got kicked bcs of this freeze...

So any news from RMA or how did you solved it?
Score
0
October 17, 2011 8:00:53 PM

Caparrso said:
I bought 6950 too, and i got same problem, the game was runing fine but now i got same lag, freeze at start issue as you, i was trying same as you changing catalyst settings, in cata ive just changed power control +20%.. tried fresh instal of windows.. but still the same. Sometime it freezes even in game fan slows down, after several sec it starts running again but some servers autokick players with high pings, so i got kicked bcs of this freeze...

So any news from RMA or how did you solved it?


im having the same problem.. and im getting sick of this lag.. Every single time I start Cod: BO or any other new game maps start at rounds beginning. I have allso noticed that Dirt 3 had some weird lags middle of the game (screen started lagging randomly and i could not control my car) Any ideas or is this just AMD's f**ked up card?

btw. I had GTX 260 before= BO worked fin on high graphs, now im lagging like hell and dont know what to do..
Score
0
October 17, 2011 11:36:16 PM

This topic has been closed by Mousemonkey
Score
0
!