Update asrock uefi

Hello,
I'm trying to update asrock'uefi with USB...i have a z68 mobo....in what folder i must put the update file?
thanks
23 answers Last reply
More about update asrock uefi
  1. It has to be empty, the USB stick and formatted Fat32 and than follow the procedure.
  2. so i've only to format the usb in fat32 and put the file on the usb without create any folder?
  3. Yes.

    ASRock Instant Flash is a BIOS fl ash utility embedded in Flash ROM.
    This convenient BIOS update tool allows you to update system BIOS
    without entering operating systems fi rst like MS-DOS or Windows®.

    With this utility, you can press <F6> key during the POST or press <F2> key to
    BIOS setup menu to access ASRock Instant Flash. Just launch this tool
    and save the new BIOS fi le to your USB fl ash drive, fl oppy disk or hard
    drive, then you can update your BIOS only in a few clicks without preparing an additional fl oppy diskette or other complicated fl ash utility. Please
    be noted that the USB fl ash drive or hard drive must use FAT32/16/12 fi le
    system.
  4. i did it! i downloaded the file z68p3m2.10 file the last bios versione for my mobo but instant flash doesn't recognized it...
  5. Whats your mobo?
  6. asrock z68 pro3-m
  7. Make sure u don't use the USB3 port!
  8. nothing...always says "no image file detected"....it could that fake extension? (.10)
  9. Can u please tell me your procedure?
  10. no....it's not!i just tried....maybe a problem with the pen....
  11. Method 1:

    Save the BIOS files on a device such as USB disk (FAT32 format), hard disk (FAT32 format) and floppy drive.
    Press <F2> during POST to get into BIOS setup menu.
    Select the utility under [Smart] menu to execute it.
  12. Method 2:

    Save the BIOS files on a device such as USB disk (FAT32 format), hard disk (FAT32 format) and floppy drive.
    Press <F6> when you see this (or similar) page.
  13. i accessed to instant flash utility with booth method but nothing appened, or nothing is recognized...
  14. Could be the stick.

    What model and brand is it?
  15. Sorry to pick up an old thread but I have the same issue.

    Tried with two usb sticks - Toshiba and TDK, both formatted under FAT32.
    Image file cannot be found.

    Any help would be highly appreciated.

    Thanks.
  16. You would get the same message if the downloaded BIOS is actually for another model. Please double-check the model name on the main page of UEFI setup:



    The file that you download from ASRock's website is a zip file. It has to be unzipped first.

    The USB stick has to be formatted as FAT32 and connected to a USB2.0 port as Nikorr mentioned.
  17. Hi Zjenep, thanks for the reply.

    Yup - same bios, same motherboard - z68 Extreme 3 Gen3. BIOS confirms the model and current BIOS version - 1.20.

    Tried three USB sticks today, all formatted as FAT32 and all tried in both USB ports at the back of the tower.
    And yes, I am unizpping the archive, tried - 2.10, 2.20, 2.30 (all available for the mobo).

    Even partitioned my HDD, small partition, FAT32, copied, zip, unzipped, just to check - same message.
    I've put keyboard on a front port, so nothing else except keyboard in the front and USB stick at the back... no success.

    I doubt that I should remove videocard, RAM, etc.

    Rest of the setup is:
    i2500k
    Radeon 7870
    16GB RAM Kingston @ 1.5 V (4x4)
    1TB HDD Seagate
    1TB HDD WD Black

    Oh and mild overclock at 4.2GHz, which was removed before I started update. BIOS is at defaults currently.
    No troubles with the setup - everything runs smoothly, no blue screens, no fatal errors in log files.
  18. Hi deaglee, seems like you tried everything. Time to look for a workaround.

    1. If you can find another Z68 Extreme3 Gen3 owner, maybe you can send him the chip and ask him to hotflash it with the latest BIOS version.

    2. Some shops sell ROM chips flashed with the version you want to have. In Europe for example:
    http://www.bios-service-center.com/
    http://www.biosflash.com/e/index.htm

    3. You can contact ASRock technical support and ask them nicely for a flashed chip. Maybe you'll get lucky. Or maybe they can offer an alternative update method that you can try.

    Good luck!
  19. Well, guess I am running out of options.
    Today tried to remove the Hard drives, even left only one stick of ram, everything that is not needed to run the pc and use the bios.

    I've reset CMOS, entered BIOS and... "Image file could not be found"

    Will see if anything from AsRock support comes up.

    Thank you.

    PS: I've attached external HDD drive to USB 2.0 at the back. Created a partition 200Mb, formatted it at FAT32, copied BIOS.
    Turned off the pc, detached everything except keyboard and mentioned drive - voila, image found and successfully updated.

    Hope this is useful for others, having the same issue.
  20. Just wanted to provide a quick response on this since I had similar issues with flashing the firmware on an asrock x99m 3.1 usb Motherboard. The asrock website is so poorly designed that it is very easy to confuse download locations and different boards. Also the fatality x99 and x99m have almost identical firmware download pages and for that matter similarly named upgrade files. If you get the message no image file detected there is a chance that you are simply downloading the wrong file. Double and triple check the file download location and name so that you know that you are downloading the proper firmware for your board. Other then that unzip the file and stick it in the top level of the usb and you are golden. F you asrock for making this dumbass bang a head against the wall for two nights.
  21. nikorr said:
    Make sure u don't use the USB3 port!


    I was getting a missing image file but I had it in a 3.0 usb port. You saved me a lot of time, thanks for mentioning this. I had to thank you.
  22. Druminfected said:
    nikorr said:
    Make sure u don't use the USB3 port!


    I was getting a missing image file but I had it in a 3.0 usb port. You saved me a lot of time, thanks for mentioning this. I had to thank you.


    What if you don't have any USB 2.0 ports on the motherboard or case? I am having the same exact issue where the BIOS isn't detected on the USB, but unfortunately the board I have, an AsRock Z170 Extreme4 has only USB 3.0 ports.


    Update: Still no resolution. I attempted to put the updated BIOS on the root of the main OS hard drive and that didn't get detected either. So far the best I have been able to do is update using the built in "Internet Flash" which downloads a bios from the network, but unfortunately that BIOS version is 1.70 and the most recent BIOS version is 3.40.

    I need these updates, my os(linux) needs them badly. Any other ideas to get out of this catch-22?
Ask a new question

Read More

ASrock USB Motherboards