Sign in with
Sign up | Sign in
Your question

Not enough memory to run MS Office in Windows 7

Tags:
Last response: in Windows 7
Share
January 3, 2010 6:50:23 PM

"Not enough memory to run Microsoft Excel. Please close other applications and try again." is the error message I get when I try to open Excel. The same message appears when trying to open other MS Office applications (e.g., Word, PowerPoint, etc.). No error codes appear just the message quoted here.

In addition, I try to open Explorer and it is non-responsive and I get a message that says, “Windows is trying to identify the problem. Windows is checking online for a solution to the problem.” but no solution is found. This happens on both of my Windows 7 Pro builds – both clean installs (one netbook with Win 7 Pro x32 and a desktop with an x64 build).

Some other helpful notes…
• This seems to happen when I leave the machines running, inactive (all power saver and screen saver functions are turned off).
• During the issue I ran RESMON and my RAM was 56% in use, which is strange because all apps are closed.
• When I restart the machine the issues stop and the RAM in use drops down to normal range.
• System has enough free storage capacity.

I don’t know what is causing the conflict to create this issue randomly. I thought about doing a clean install of MS Office, but both my machines are having the same problem and a buddy of mine is having the same problem as well, so not sure that is the best route – thought it might be a conflict with Win 7 and maybe Office 2007 Enterprise? Searching for other forums on this turns up little guidance, but some people have suggested a permissions issue – I do not have admin passwords set up for either install (I hate having to log in). Ideas or thoughts from anyone who has encountered this issue would be much appreciated.

Here are my builds for reference:

Desktop (home build) – all updates current
OS – Windows 7 Professional x64
CPU - AMD Athlon II X4 620 Propus 2.6GHz Socket AM3 95W Quad-Core Processor
RAM - Patriot Viper 4GB DDR2 1066 (PC2 8500)
MoB - ASRock A780GXH
HDD - WD Caviar Black 640GB (300 GB free)
Software – Win 7 Pro x64, MS Office 2007 Enterprise, Panda AntiVirus 2010, HP Mediaserver 2003 (nightly back up), IOBit Security 360, IE8, other misc software

Netbook (IBM Thinkpad X41) – all updates current
OS – Windows 7 Professional x32
CPU – Intel Pentium M 1.5 GHz
RAM – 2 GB
HDD - 52GB (29 GB free)
Software – Win 7 Pro x64, MS Office 2007 Enterprise, Panda AntiVirus 2010, HP Mediaserver 2003 (nightly back up), IOBit Security 360, IE8, other misc software

Sorry for the long post, but I wanted to make sure you have all the details up front. Thanks fr your help.
a b $ Windows 7
January 4, 2010 2:40:27 PM

I am running the same processor,2G ram and version of office, W7 X86 Ultimate with no problems, but my ram is allways at 30-50% at idle, opening the task manager and the memory usage listed for all processes does not add up to what my desktop gadget shows, so what is really going on
m
0
l
a b $ Windows 7
January 4, 2010 4:59:28 PM

Try disabling IOBit 360. It got a terrible review at PCMag. Plus, running it side-by-side with another security program (Panda) is just asking for trouble.
m
0
l
Related resources
January 5, 2010 3:19:01 AM

Bolbi - thanks for the reply. Wow! PC Mag scorched IObit 360. I agree that having two security programs is trouble, so I will uninstall tomorrow. In the meantime, someone suggested turning off the page file which I know can be a little risky, but the problem has gone away in the last 24 hours since trying this. I need to test a little more before confirming and then I'll get rid of IOBit. Thanks again!
m
0
l
a b $ Windows 7
January 5, 2010 12:06:56 PM

Hmm... Turn OFF the pagefile? If the program is already complaining about not enough RAM, I don't see how reducing the amount of virtual (sort of like overflow) memory is going to help. I guess it's worth a try. Just don't do that with anything important open. Windows gives a warning that setting the pagefile below 200 MB may not allow the OS to properly record details to help resolve the problem if the computer crashes. Ergo, I leave mine at 200. Never had a problem (running Office 2010 x64 beta).
m
0
l
January 9, 2010 3:40:36 PM

Update: I still have the pagefile off and have been monitoring both machines over the last few days. I also uninstalled IOBit 360 on the netbook, but not the desktop to test that fix as well. Turns out that I am still having the issue, but it appears to ONLY be happening on the desktop so maybe IOBit is contributing to the concern. I'm going to uninstall on the desktop and then continue the test. I also plan to move the pagefile up to min levels, but I'll wait until after this test to make that change. Thanks again for your thoughts and ideas!
m
0
l
a b $ Windows 7
January 10, 2010 11:41:36 AM

twodals said:
I also plan to move the pagefile up to min levels, but I'll wait until after this test to make that change.
With 4GB or RAM on the Desktop use the 'Let Windows decide" on the size of the page file.
m
0
l
a b $ Windows 7
January 10, 2010 1:16:05 PM

WR2 said:
With 4GB or RAM on the Desktop use the 'Let Windows decide" on the size of the page file.

Unless you really have a lot of RAM-heavy stuff going, the average user will be fine with the minimum pagefile (200 MB). I have my 4GB desktop set to that, and have never had a problem multitasking or even running some older-ish games (e.g., Star Wars Battlefront II) with all my normal programs still open in the background (Firefox, Thunderbird, Word, etc.).
I agree, though, that for the average user looking to not have any problems whatsoever no matter how much stuff they want to run at once, they should either set a larger pagefile manually, or let Windows manage it for them.
m
0
l
January 10, 2010 8:21:23 PM

Bolbi said:
Try disabling IOBit 360. It got a terrible review at PCMag. Plus, running it side-by-side with another security program (Panda) is just asking for trouble.



Worked for me! As soon as I exited IOBIT360, word and excel worked
fine even without a reboot. Oh, and this was my office computer,
with Windows XP. Its working fine on my Windows 7 but then again I
don't have IOBIT360 on Win7.

Thanks!
m
0
l
a b $ Windows 7
January 10, 2010 10:15:51 PM

subbywrx said:
Worked for me! As soon as I exited IOBIT360, word and excel worked
fine even without a reboot. Oh, and this was my office computer,
with Windows XP. Its working fine on my Windows 7 but then again I
don't have IOBIT360 on Win7.

Thanks!

Glad it worked for you! Seems IOBIT360 and Office don't get along... :D 
@twodals: Does disabling IOBIT360 also fix the problem on your desktop?
m
0
l
January 15, 2010 1:01:46 PM

Yes! After several more days of testing to make sure it wasn't a fluke, both systems are now operating with no apparent conflicts. Removing IOBit 360 seems to have done the trick. When I run RESMON now I still have (what seems to be) a lot of RAM in use (32-40% on average with little to no active windows open), but the system operates normally - no issues - no conflicts. Thanks again for all your help. I hope someone else will benefit from this troubleshooting effort as well.
m
0
l
a b $ Windows 7
January 15, 2010 1:05:51 PM

Hmm... This is probably a common problem if two users here happened to notice it already. I wonder if IOBIT knows about this incompatibility.
m
0
l
a b $ Windows 7
January 15, 2010 1:40:02 PM

twodals said:
When I run RESMON now I still have (what seems to be) a lot of RAM in use (32-40% on average with little to no active windows open), but the system operates normally - no issues - no conflicts.
This is not a bad thing and what you're seeing is actually a feature of Windows called SuperFetch that pre-loads software into memory to reduce their access & load times. SuperFetch monitors which applications you use the most and pre-loads these into your system memory so they'll be ready when you need them. Why have all that memory and let it sit around not doing anything?

m
0
l
January 16, 2010 8:53:24 PM

Good to know - thanks!!
m
0
l
!